Website Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • August 30, 2015, 09:34:33 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: My own posts showing up in Unread Posts - Am I the only one experiencing this?  (Read 3797 times)

Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 7,039
    • View Profile
    • Just for mouser.
    • Donate to Member
The way I use the forums might be a bit odd. I pretty much only use the Unread Posts link (my bookmark is straight to that link!) so I can see what's changed since I last checked. I don't go looking into specific sections. In fact, I hardly pay attention to what section anything is in except for when I'm creating my own posts.

But ever since the DC server upgrade a couple months ago my own posts that I've just made will often show up in the Unread Posts. How can it be unread when I wrote it? But it gets worse. Even if I click on them to view them, or if I check the box and select "Mark selected posts as read" they will often still show up for in the unread posts. Eventually after trying multiple times it will "stick" and no longer show up on my unread posts list. I haven't been able to work out exactly what the pattern is, but it seems to be based more on time than the number of times I try to mark it as read. That is, if it's been a couple minutes since I made the post, then marking it as read will usually stick. But if I just made a post within the past 60 seconds then marking it as read is usually a fruitless endeavor.

It doesn't happen every time, but it happens often enough that it's become very annoying. Am I the only person experiencing this? I've been bugging mouser on IRC to fix it for a while but he doesn't know what's wrong.

Unread Posts.png

« Last Edit: August 22, 2011, 02:51:34 PM by Deozaan, Reason: added pic of problem »

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 34,932
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Donate to Member
im fairly sure this is a bug that crops up because of the approximate way smf forums handled the markunread feature with such a large number of posts.  i think i remember seeing some discussion of it on the smf community forums.  see if you can find a thread discussing it that might have some clues.

Eóin

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 1,401
    • View Profile
    • Donate to Member
The way I use the forums might be a bit odd. I pretty much only use the Unread Posts link (my bookmark is straight to that link!) so I can see what's changed since I last checked. I don't go looking into specific sections. In fact, I hardly pay attention to what section anything is in except for when I'm creating my own posts.

If that's odd then I'm odd too, cause that's exactly how I browse the forum. Sorry for the OT :)

ewemoa

  • Honorary Member
  • Joined in 2008
  • **
  • Posts: 2,698
    • View Profile
    • Donate to Member
I don't know if it's related but I noticed that my own posts show up under "Show new replies to your posts".  I don't remember it being this way before...but then my memory isn't the most reliable thing in the world :)

TucknDar

  • Charter Member
  • Joined in 2005
  • ***
  • Posts: 1,096
    • View Profile
    • Read more about this member.
    • Donate to Member
The way I use the forums might be a bit odd. I pretty much only use the Unread Posts link (my bookmark is straight to that link!) so I can see what's changed since I last checked. I don't go looking into specific sections. In fact, I hardly pay attention to what section anything is in except for when I'm creating my own posts.

If that's odd then I'm odd too, cause that's exactly how I browse the forum. Sorry for the OT :)
Me too (both the browsing and the being sorry for OT part)  :-[

phitsc

  • Honorary Member
  • Joined in 2008
  • **
  • Posts: 1,093
    • View Profile
    • Donate to Member
The way I use the forums might be a bit odd. I pretty much only use the Unread Posts link (my bookmark is straight to that link!) so I can see what's changed since I last checked. I don't go looking into specific sections. In fact, I hardly pay attention to what section anything is in except for when I'm creating my own posts.

If that's odd then I'm odd too, cause that's exactly how I browse the forum. Sorry for the OT :)
Me too (both the browsing and the being sorry for OT part)  :-[

Me too. I've never experienced the problem mentioned though.

cyberdiva

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 962
    • View Profile
    • Donate to Member
I too generally use only Unread Posts to see what's new since the last time I looked.  But I don't recall seeing my posts show up there.

JavaJones

  • Review 2.0 Designer
  • Charter Member
  • Joined in 2005
  • ***
  • Posts: 2,636
    • View Profile
    • Read more about this member.
    • Donate to Member
I only use Unread Posts as well (except when I'm posting a new one). Occasionally I'll see one of my message replies in there, but very infrequently. Not sure about *new* thread posts of mine though.

- Oshyan

Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 7,039
    • View Profile
    • Just for mouser.
    • Donate to Member
Occasionally I'll see one of my message replies in there, but very infrequently. Not sure about *new* thread posts of mine though.

For me it will be either replies to existing threads or new threads I create. It doesn't really matter. Any time I make a post, it's very likely that it will show up on my unread posts list. >:(


steeladept

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 1,059
    • View Profile
    • Donate to Member
Looks like that is a fairly common way of using the forums as I do exactly the same thing.  And yes, I see the same thing too.  I generally just ignore them. (Unless there are replies that is).

Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 7,039
    • View Profile
    • Just for mouser.
    • Donate to Member
mouser and I have been working on figuring this thing out, and it appears as though it happens to me only when I'm using DC on secure HTTPS. When I use just HTTP then I don't have this problem.

Can anyone else verify/duplicate this?


Stoic Joker

  • Honorary Member
  • Joined in 2008
  • **
  • Posts: 5,878
    • View Profile
    • www.StoicJoker.com
    • Donate to Member
Does it have to be a new post? Or will a reply do? (posted via https)

Stoic Joker

  • Honorary Member
  • Joined in 2008
  • **
  • Posts: 5,878
    • View Profile
    • www.StoicJoker.com
    • Donate to Member
I'll guess it goes either way. Just checked https all unread link, and there I was right at the top.

Stephen66515

  • Animated Giffer in Chief
  • Honorary Member
  • Joined in 2010
  • **
  • Posts: 2,994
    • View Profile
    • Donate to Member
This seems to be a pretty forum-wide thing, noticed it on several other forums, but didnt think anything of it till this post