Blowssi - Perl v5.10.1 - 2/3 subtests failed -
Welcome Guest.   Make a donation to an author on the site August 28, 2015, 02:32:51 AM  *

Please login or register.
Or did you miss your validation email?

Login with username and password (forgot your password?)
Why not become a lifetime supporting member of the site with a one-time donation of any amount? Your donation entitles you to a ton of additional benefits, including access to exclusive discounts and downloads, the ability to enter monthly free software drawings, and a single non-expiring license key for all of our programs.

You must sign up here before you can post and access some areas of the site. Registration is totally free and confidential.
Check out and download the GOE 2007 Freeware Challenge productivity tools.
   Forum Home   Thread Marks Chat! Downloads Search Login Register  
Pages: [1]   Go Down
  Reply  |  New Topic  |  Print  
Author Topic: Blowssi - Perl v5.10.1 - 2/3 subtests failed  (Read 3166 times)
Posts: 5

View Profile Give some DonationCredits to this forum member
« on: April 18, 2011, 02:42:31 PM »


I'm having some issues building blowssi and tbh, i'm no wizzard with Perl.
This is all the information i have and i can only hope for some help here:

OS: Xubuntu 10.10
Perl: v5.10.1
Blowssi: v0.2.0
running as root just to be extra clear here..

This is what i get from "make test" on Crypt-ircDH1080-0.01:
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/Crypt-ircDH1080.t .. 1/2
#   Failed test at t/Crypt-ircDH1080.t line 21.
# Looks like you planned 2 tests but ran 3.
# Looks like you failed 1 test of 3 run.
t/Crypt-ircDH1080.t .. Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/2 subtests

Test Summary Report
t/Crypt-ircDH1080.t (Wstat: 256 Tests: 3 Failed: 2)
  Failed tests:  2-3
  Non-zero exit status: 1
  Parse errors: Bad plan.  You planned 2 tests but ran 3.
Files=1, Tests=3,  0 wallclock secs ( 0.02 usr  0.00 sys +  0.15 cusr  0.00 csys =  0.17 CPU)
Result: FAIL
Failed 1/1 test programs. 2/3 subtests failed.
make: *** [test_dynamic] Error 1

I ran into some issues with a lot of libraries, like Crypt::Random, doesn't excist in my distro aparently so i took some help from #perl and they gave me these instructions:
curl -L | perl - --sudo App::cpanminus
cpanm -S Crypt::Random
That did the trick for that module, had some others but i simply replaced the dashes in the error message with :: and tried:
cpanm -S <Module::Thing::here> and it worked, and i got this faar.

I'll supply any details you need, i can rerun the entire command history just to get this working tbh.
I'm just so new to Perl so i don't really know what you expect when you debug, if you'd be using Python, C++, C# you name it i'd probably be of more use, so, if you need any info at all, poke me! i'll probably hang around irc for some time hoping for an answer (nick on efnet is Torxed tho)

Thank you in advance from the bottom of my heart!
« Last Edit: April 18, 2011, 02:45:31 PM by DoXiD; Reason: Wrong title, didn\'t explain a thing! » Logged
DC Server Admin
Charter Honorary Member
Posts: 857

see users location on a map View Profile WWW Give some DonationCredits to this forum member
« Reply #1 on: April 19, 2011, 12:34:12 AM »

You might be able to get away with just skipping the make test step.

I'm not the author of Crypt-ircDH1080 so you might want to ask whoever made that module.
All I can say is that it works fine here on perl v5.12.2
It's pretty hard to debug stuff without ssh access over a forum smiley
Posts: 5

View Profile Give some DonationCredits to this forum member
« Reply #2 on: April 19, 2011, 01:12:17 AM »

Wow, everything i've learned, i've learned from trynig things without reading up on it first.
This has given me a hughe advantage in trying to find solutions on problems when it comes to computers..

But i couldn't even try a simple thing such as just skipping the test tongue
Gothi[c], you were right, i got away with just running "make" -> "make install" smiley

Thank you for this, i honestly don't think i would have solved it due to lack of brainfunction on my part ^^
Pages: [1]   Go Up
  Reply  |  New Topic  |  Print  
Jump to:  
   Forum Home   Thread Marks Chat! Downloads Search Login Register | About Us Forum | Powered by SMF
[ Page time: 0.034s | Server load: 0.09 ]

Share on Facebook
submit to reddit