Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 02, 2016, 02:06:01 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: SOLVED: get back my "Open with..."?  (Read 5850 times)

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 7,089
    • View Profile
    • Donate to Member
SOLVED: get back my "Open with..."?
« on: April 08, 2011, 12:39:42 PM »
PROBLEM SOLVED   :)
--------------------

a crappy program removed all of my third party program's entries from my Vista's right-click context menu. I don't remember if my "Open with..." long ago was modified by a third-party program, (I am me, so I guess it was), but also "Open with..." has gone, from every file type that I have checked, and I have no idea how to get it back.

I really need to get back my "Open with..."! Please?  :tellme:
« Last Edit: April 08, 2011, 07:17:07 PM by Curt »

skwire

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 4,664
    • View Profile
    • Donate to Member
Re: how do I get back my "Open with..."?
« Reply #1 on: April 08, 2011, 01:02:47 PM »
Try following the instructions here: http://support.microsoft.com/kb/218805

Winkie

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 82
    • View Profile
    • Donate to Member
Re: how do I get back my "Open with..."?
« Reply #2 on: April 08, 2011, 01:34:25 PM »
Try following the instructions here: http://support.microsoft.com/kb/218805

Thanks for the link, Skwire. Now I was able to finally fix this problem on my XP pc:
Quote from: MS KB
SYMPTOMS
When you double-click an unknown file type, an unexpected default action may occur.

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 7,089
    • View Profile
    • Donate to Member
Re: how do I get back my "Open with..."?
« Reply #3 on: April 08, 2011, 03:53:19 PM »
Try following the instructions here: http://support.microsoft.com/kb/218805
Quote from: Microsoft Knowledge Base
Use Registry Editor to examine the file association key for unknown file types:
HKEY_CLASSES_ROOT\Unknown\shell\openas\command
The "default" value for this key should read:
C:\%windir%\rundll32.exe shell32.dll,OpenAs_RunDLL %1

my Vista reads:
%SystemRoot%\system32\rundll32.exe %SystemRoot%\system32\shell32.dll,OpenAs_RunDLL %1

I would guess it is the same? So the problem may have been caused elsewhere? Hmm...

Info:
There is also key with the name DelegateExecute. Its' value data:

{e44e9428-bdbc-4987-a099-40dc8fd255e7}

However, the one above is named openas and does not have any data defined. My guess would be that this could be the problem. But of course I have no idea what it maybe should read.

HKEY_CLASSES_ROOT\Unknown\

b1 2011-04-08_231303.gif
a2 2011-04-08_224646.gif
a3 2011-04-08_224721.gif
a4 2011-04-08_224854.gif


?  :tellme:
« Last Edit: April 08, 2011, 04:14:14 PM by Curt »

MilesAhead

  • Supporting Member
  • Joined in 2009
  • **
  • Posts: 7,275
    • View Profile
    • Miles Ahead Software
    • Donate to Member
Re: how do I get back my "Open with..."?
« Reply #4 on: April 08, 2011, 03:59:15 PM »
Curt I'd take a look at this tutorial:

http://www.vistax64....pen-add-program.html

Unfortunately they named the domain "vistax64" but it applies to all versions of Vista.  It's the best Vista specific site I've found.

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 7,089
    • View Profile
    • Donate to Member
Re: how do I get back my "Open with..."?
« Reply #5 on: April 08, 2011, 04:18:14 PM »
Thank you, Miles

It looks almost dangerous...



I will take a closer look tomorrow when I have had some sleep!

Winkie

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 82
    • View Profile
    • Donate to Member
Re: how do I get back my "Open with..."?
« Reply #6 on: April 08, 2011, 04:39:36 PM »
my Vista reads:
%SystemRoot%\system32\rundll32.exe %SystemRoot%\system32\shell32.dll,OpenAs_RunDLL %1
I would guess it is the same?
They are the same, but when you can always try to subsitute both %Systemroot% for %WinDir%. That surprisingly fixed it on my XP! :tellme:

MilesAhead

  • Supporting Member
  • Joined in 2009
  • **
  • Posts: 7,275
    • View Profile
    • Miles Ahead Software
    • Donate to Member
Re: how do I get back my "Open with..."?
« Reply #7 on: April 08, 2011, 05:23:43 PM »
Thank you, Miles

It looks almost dangerous...



I will take a closer look tomorrow when I have had some sleep!


A good way to back up your registry hives short of a Restore Point is ERUNT.
Restoring the registry from it is much less involved than using a restore point.

http://larshederer.h...e.t-online.de/erunt/

The dude Brink on the Vista site is in charge of the tutorials. He knows his stuff.  Still, it doesn't hurt to back up registry hives first. It's only around a 50 MB folder for a backup.


sajman99

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 664
    • View Profile
    • Donate to Member
Re: how do I get back my "Open with..."?
« Reply #8 on: April 08, 2011, 06:37:48 PM »
Here is another resource. Supposedly the provided .reg file works on both Windows 7 and Vista.

http://www.sevenforu...item-add-remove.html

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 7,089
    • View Profile
    • Donate to Member
Re: how do I get back my "Open with..."?
« Reply #9 on: April 08, 2011, 07:15:48 PM »
Here is another resource. Supposedly the provided .reg file works on both Windows 7 and Vista.
http://www.sevenforu...item-add-remove.html

PERFECT!!   :-*

Many thanks to all of you for helping me out on this,
and one special extra Thank You to sajman99 :Thmbsup:

sajman99

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 664
    • View Profile
    • Donate to Member
Re: SOLVED: get back my "Open with..."?
« Reply #10 on: April 09, 2011, 12:12:21 PM »
Curt, you're welcome. I'm glad to know the .reg file worked.  :)

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 7,089
    • View Profile
    • Donate to Member
Re: SOLVED: get back my "Open with..."?
« Reply #11 on: April 09, 2011, 04:27:09 PM »
NB! It should be noted that the registry keys (on the above shown screenshots) still are exactly as they were before the fix, because the address for the proper key was quite different:

Quote from: save as 'Restore OpenWith.reg'
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shellex\ContextMenuHandlers\Open With]
@="{09799AFB-AD67-11d1-ABCD-00C04FC30936}"

[HKEY_CLASSES_ROOT\*\shellex\ContextMenuHandlers\Open With EncryptionMenu]
@="{A470F8CF-A1E8-4f65-8335-227475AA5C46}"

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 7,089
    • View Profile
    • Donate to Member
Re: SOLVED: get back my "Open with..."?
« Reply #12 on: April 10, 2011, 04:54:37 PM »
Disable / Restore "Send To..." system Menu:

http://www.howtogeek...plorer-context-menu/

Quote from: HowToGeek
* SendTo-DisableRestore.zip (0.6 kB - downloaded 113 times.)

Tested on my 32-bits Vista


MilesAhead

  • Supporting Member
  • Joined in 2009
  • **
  • Posts: 7,275
    • View Profile
    • Miles Ahead Software
    • Donate to Member
Re: SOLVED: get back my "Open with..."?
« Reply #13 on: April 10, 2011, 07:49:19 PM »
This one can also be handy for shell context menu:

http://www.nirsoft.n...shell_menu_view.html

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 7,089
    • View Profile
    • Donate to Member
Re: SOLVED: get back my "Open with..."?
« Reply #14 on: April 11, 2011, 12:47:02 AM »
-yes, it is terrific, but maybe a little overwhelming, when looking at 296 items... :-[

I use CFi ShellToys, which include the pictured bottom line, "Rarely Used..."

This is for a text file:

CFi2011-04-11.gif



This solution has turned out to be more trustworthy, because it doesn't alter or remove any keys, things are either 1) on display, 2) rarely used, or 3) hidden (edited: nothing is hidden in my setup).
« Last Edit: April 11, 2011, 07:16:09 AM by Curt »

sajman99

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 664
    • View Profile
    • Donate to Member
Re: SOLVED: get back my "Open with..."?
« Reply #15 on: April 11, 2011, 01:02:15 PM »
This one can also be handy for shell context menu:
http://www.nirsoft.n...shell_menu_view.html

Yep, and Nirsoft's ShellExView is another useful context tool.

Also, I have used OpenExpert on my XP machine for many years. Too bad this "Open with" replacement doesn't work on Vista/Win7. :(