Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 04, 2016, 02:26:14 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Settings Not Saved When SSC is Updated in 2.89.01  (Read 1529 times)

J-Mac

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 2,913
    • View Profile
    • Donate to Member
Settings Not Saved When SSC is Updated in 2.89.01
« on: February 02, 2011, 11:41:14 AM »
mouser,

After the last Screenshot Captor update to 2.89.01 I noticed that my settings were not saved from the installed version that SSC updated. E.g., all my "Move To..." folder settings were wiped, the display/UI settings were all dumped, and the setting that creates folders by date and auto-moves screenshots into them was reset (I usually have this feature disabled, never liked it at all!!) SSC has a LOT of settings and so resetting them all manually is not necessarily a small task.

So how come the installer is now wiping all the settings, requiring a manual redo of them one-by-one? If this is to continue I'm going to have to save all my settings before updating from now on. Or just stop updating till I see if it's worth the trouble.

I'm using Screenshot Captor 2.89.01 on Windows 7 Home Premium.

Thanks!

Jim

Edit: OK, I located a backup of the file ScreenshotCaptor.ini and replaced the newer file with it. All settings have now gone back to what they were. Any problems with using the prior version's .INI file with 2.89.01?
« Last Edit: February 02, 2011, 11:55:15 AM by J-Mac »

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Settings Not Saved When SSC is Updated in 2.89.01
« Reply #1 on: February 02, 2011, 11:35:40 PM »
the new version doesn't wipe out any settings, and the old ini files are 100% compatible.
something else must have happened.. perhaps causing SC to lose your old settings file.  I'm not sure what that would be though.

J-Mac

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 2,913
    • View Profile
    • Donate to Member
Re: Settings Not Saved When SSC is Updated in 2.89.01
« Reply #2 on: February 03, 2011, 12:17:25 AM »
Hmm. Not sure what could have happened, though fortunately I have some ultra-redundant backups and was able to easily recover the old ini file.

Thank you.

Jim