Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 09, 2016, 01:19:49 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Last post Author Topic: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010  (Read 25196 times)

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,429
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #25 on: December 19, 2010, 04:57:15 PM »
the registrar is TotalChoice hosting, but the reason the nameserver propagation happened so incredibly fast is due to a few things, that maybe Gothi[c] can elaborate on:

  • We set the TLS to lowest values weeks ago, which informs everyone that they have to recheck often for possible changes in the DNS.
  • We still have the old server up and changed its nameserver data to point to the new server -- so even when the old server was queried it had info about the new server.

These two things mean that most people got updated to the new server dns in minutes instead of days.  Again you can thank Gothi[c] the DC server admin for knowing how to do this.  :up:

Ashraf

  • Supporting Member
  • Joined in 2009
  • **
  • Posts: 45
    • View Profile
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #26 on: December 19, 2010, 05:17:21 PM »
Mouser,

Very clever; I need to remember to change the TLS when moving servers.

I will look into TotalChoice as a domain registrar, but I am leaning towards Internet.bs as my next domain registrar. I have heard really good things about them and they are the cheapest around.

Cheers Gothi[c].

y0himba

  • Charter Member
  • Joined in 2005
  • ***
  • Posts: 435
  • Yar.
    • View Profile
    • y0himba.net
    • Read more about this member.
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #27 on: December 20, 2010, 05:14:09 AM »
I have been with Dreamhost for YEARS and have had no issues except for the occasional Jabber server reset.  Never been happier and I host 12 domains with them.
My Web Site:  http://www.y0himba.net

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,429
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #28 on: December 25, 2010, 08:49:20 AM »
Am i the only one experiencing DC forum as being very fast to browse, but as having gotten verrrrrry sloooooooooooowwwwwww shen you submit a new post (or post modication).

40hz

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 11,768
    • View Profile
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #29 on: December 25, 2010, 09:06:41 AM »
Am i the only one experiencing DC forum as being very fast to browse, but as having gotten verrrrrry sloooooooooooowwwwwww shen you submit a new post (or post modication).

Add me to the list. (And here I though it was just a lousy wifi connection)

JavaJones

  • Review 2.0 Designer
  • Charter Member
  • Joined in 2005
  • ***
  • Posts: 2,717
    • View Profile
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #30 on: December 25, 2010, 03:12:18 PM »
Same here, I meant to mention that problem earlier. Glad someone else noticed.

- Oshyan

f0dder

  • Charter Honorary Member
  • Joined in 2005
  • ***
  • Posts: 9,029
  • [Well, THAT escalated quickly!]
    • View Profile
    • f0dder's place
    • Read more about this member.
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #31 on: December 25, 2010, 03:17:15 PM »
Testing post... post took ~5 seconds, which is a lot - browsing is instantaneous.
Now testing "save" from edit... save also took ~5 seconds.

Search is also pretty much instantaneous.

Connecting through HTTP://, not with SSL/TLS.
- carpe noctem
« Last Edit: December 25, 2010, 03:18:47 PM by f0dder »

Josh

  • Charter Honorary Member
  • Joined in 2005
  • ***
  • Points: -5
  • Posts: 3,397
    • View Profile
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #32 on: December 25, 2010, 03:18:16 PM »
BTW, the value is the TTL, not TLS. Time-To-Live sets how long a DNS entry is valid before it needs to be rechecked. Lower TTL == more frequent checking for updates.

skwire

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 4,668
    • View Profile
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #33 on: December 25, 2010, 03:23:05 PM »
Am i the only one experiencing DC forum as being very fast to browse, but as having gotten verrrrrry sloooooooooooowwwwwww shen you submit a new post (or post modication).

I experience this as well.  Sometimes, they don't post at all so I have to go back, refresh, and click the post button again.

Stephen66515

  • Animated Giffer in Chief
  • Honorary Member
  • Joined in 2010
  • **
  • Posts: 3,131
    • View Profile
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #34 on: December 26, 2010, 06:19:25 AM »
Am i the only one experiencing DC forum as being very fast to browse, but as having gotten verrrrrry sloooooooooooowwwwwww shen you submit a new post (or post modication).

I experience this as well.  Sometimes, they don't post at all so I have to go back, refresh, and click the post button again.

Last 3 or 4 posts I have noticed this also.

Kamel

  • Honorary Member
  • Joined in 2006
  • **
  • Posts: 138
    • View Profile
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #35 on: December 26, 2010, 08:07:44 AM »
Grats on the new server! :D

not sure how posting speeds are but browsing seems fine atm. will find out right now haha
I'm the guy you yell at when your DSL goes down...

40hz

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 11,768
    • View Profile
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #36 on: December 27, 2010, 10:30:26 AM »
FYI - 12/27/2010 11:00am EST - Posting to forum  is still exhibiting a noticeable delay from where I'm sitting. I'm counting 5-12 seconds from hitting <enter> to getting an updated screen returned. Even more if I include an image. I'm guessing it has to do with creating new records in MySQL since subsequent edits to a post run at close to the old forum speeds, and only bog down big time if you start adding, deleting, or re-sequencing image uploads.

I did actually have DC lock-up a few times after I swapped out different images on a post I made. I hit save, realized I had the wrong image, went in and changed it, immediately re-saved...and got a freeze up.

Once I closed FF and logged back in, the post was completely missing the image in one instance, and still displaying the old image in the second. After that, however, I was able to correct the problem and get the changes to post both times. So it seems like it's something new-record or speed related if you try to edit too quickly. It doesn't happen if I change something that's been up for a half-minute or so. And it doesn't seem to be doing it any more.

(Link or anti-spam/malware scanning possibly having something to do with it?)

No big hu-hu. Just thought you'd like to know. :) :Thmbsup:
« Last Edit: December 27, 2010, 10:35:12 AM by 40hz »

Ath

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 2,785
    • View Profile
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #37 on: December 27, 2010, 10:38:03 AM »
Well, here from the CET timezone, the same 5 to 12 sec posting-delays also occur. Also working with FF, and haven't tried Chrome, IE, Opera, or Safari (yet) as I don't expect differences if it's server-related.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,429
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #38 on: December 27, 2010, 10:38:57 AM »
we are working on the posting speed issue.. we should be able to fix it.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,429
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #39 on: December 27, 2010, 10:40:55 AM »
Let me know if the problem is fixed now please.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,429
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #40 on: December 27, 2010, 10:46:42 AM »
ps you can always make test posts that others will not see in the special Personal Area: http://www.donationc...index.php?board=55.0
« Last Edit: December 27, 2010, 11:02:48 AM by mouser »

worstje

  • Honorary Member
  • Joined in 2009
  • **
  • Posts: 571
  • The Gent with the White Hat
    • View Profile
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #41 on: December 27, 2010, 10:59:36 AM »
I am letting you know... that the problem seems fixed.

f0dder

  • Charter Honorary Member
  • Joined in 2005
  • ***
  • Posts: 9,029
  • [Well, THAT escalated quickly!]
    • View Profile
    • f0dder's place
    • Read more about this member.
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #42 on: December 27, 2010, 12:34:15 PM »
What had to be changed, mousey? (issue seems to be fixed for me as well).
- carpe noctem

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,429
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #43 on: December 27, 2010, 12:42:35 PM »
it must be some slowdown related to sending mail from the new server; i have code that emails a copy of every forum post and post mod to a special email account, as a kind of low-tech poor-mans real time offsite backup system.  disabling that seems to have fixed most of the speed problems with posting.  I say most because i'm still noticing some slow posting speeds when posting to some threads (maybe ones currently being read by many users..)

Ashraf

  • Supporting Member
  • Joined in 2009
  • **
  • Posts: 45
    • View Profile
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #44 on: December 29, 2010, 11:29:21 PM »
For what it is worth, I haven't noticed any slowdown.

EDIT: And of course just as I say that it takes 10+ seconds to make my post...  :-[

app103

  • That scary taskbar girl
  • Global Moderator
  • Joined in 2006
  • *****
  • Posts: 5,666
    • View Profile
    • App's Apps
    • Read more about this member.
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #45 on: December 30, 2010, 01:41:21 AM »
Things are still slow for me, with regards to posting speed. I would compare it to the speeds I had on the old server from a 233mhz machine on 33.6k dialup. (yeah, that's slow)

techidave

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 1,012
    • View Profile
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #46 on: December 30, 2010, 07:53:57 AM »
I experienced the delay last night during one of my posts.  

Edit: this post also was slow but not as slow as the previous one.

Edit 2: the edit was normal.
« Last Edit: December 30, 2010, 07:55:42 AM by techidave »

40hz

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 11,768
    • View Profile
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #47 on: December 30, 2010, 09:28:05 AM »
I'm still seeing the delay on initial posting. Not as long as previously, but still noticeable  Edits continue to post noticeably quicker as was noted previously.

Note: the lag seems to come and go, which tends to point to a traffic issue somewhere.  Do you see anything odd happening on the ports or with the v-NICs? I'm not super up on virtual servers (yet) but every headache I've ever had with them always went back to an issue with the network bindings.

Stephen66515

  • Animated Giffer in Chief
  • Honorary Member
  • Joined in 2010
  • **
  • Posts: 3,131
    • View Profile
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #48 on: December 30, 2010, 11:57:30 AM »
Seems to be lagging like hell when you try to atach any form of anything...

Just tried 3 times to post something in my personal area, so I could check the layout and such first, and every single time, i got timed out.

Before mouser asks...no, the image was not my usual 3MB+ file size, in fact, it was a measly 300kb (appx w300xh100)...1 singular image, no idea why its happening, or if this post will even get through lol.

Doesnt seem to be a problem on my side as I am able to visit and post on other sites.

-Stephen

*edit*

This post went through without a single problem or hint of lag.

*edit 2*

So did the last edit (Instead of getting stuck in an endless loop, im not going to post on the outcome of this edit)

Carol Haynes

  • Waffles for England (patent pending)
  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 7,986
    • View Profile
    • Dales Computer Services
    • Donate to Member
Re: DonationCoder.com NEW SERVER ACTIVATED Dec 17, 2010
« Reply #49 on: December 31, 2010, 07:05:45 AM »
Well done.

The page kept appearing and disappearing yesterday (presumably flaky DNS propogation and interesting attempts at routing).

Seem stable now though.  :-*