Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 08, 2016, 07:46:27 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: SpellWindows Object  (Read 3856 times)

chrisk

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 51
    • View Profile
    • Donate to Member
SpellWindows Object
« on: February 17, 2006, 02:39:02 PM »
(first: i apologize to make this the topic of a separate thread, after already having asked this question in another thread...where it has unfortunately disappeared in the "fog" of several other issues which i tried to raise all at the same time...my mistake)

I have specified a hotkey for SpellObject Windows. i then experimented in 4 principal applications which i use for text input:
Metapad (txt)
ETabula (rtf)
Foxmail Compose (email client)
Opera (browser)

..and it works flawlessly in Notepad (Metapad), a bit so-so in a rtf editor (ETabula), and not at all in "compose" windows of Foxmail (email client) nor in Opera (input windows).

in the first case, _without any selecting of text_, i get (upon hitting the hotkey) correct highlighting of misspelled words and correctly functioning spellchecker.

in the second case (ETablua), i get three "access violation errors" (i assume that is the correct english translation for "zugriffsverletzung")...which i can "click through"...and then end up with a correct misspelled-words highlighting and a functioning spellchecker. this happens both with, and without, selecting of text.

in the third and fourth case, _without selecting of text_, i get an error message
"the selection has been checked. would you like to check the remainder of the document?".
answering yes or no makes no difference...no highlighting of misspelled words, no spellchecking, no clippping to CHS happens.
if i _select/highlight_  text (in a Compose(Foxmail) or in Opera) and attempt to go directly to spellcheck via the SpellWindows Object hotkey, same result as above, ie nothing.
if i _select/highlight-  text and use the CHS hotkey (Ctrl+Alt+V), the CHS main window will come to the foreground, misspelled words will be underlined red, spellchecking functions properly, and pasting back works OK.
(however, is it possible to change fontsize in the CHS text window? and is it possible to not _underline_ red but to highlight, the same way as in Notepad?)

is there anything i can/should do to "enable" direct spellchecking (in the second case without access violations, in the third without having to go via CHS editing window)???
is this a dll problem?
how do i find out whether/which files may be missing in my OS?

thanks for any help!



chrisk

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 51
    • View Profile
    • Donate to Member
Re: SpellWindows Object
« Reply #1 on: March 08, 2006, 11:20:17 AM »
...nobody??
help!
chrisk

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,421
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: SpellWindows Object
« Reply #2 on: March 08, 2006, 11:23:20 AM »
sorry i missed this the first time chrisk -

you aren't missing any files - it's just an experimental feature that needs more perfecting.
i will try to come back to it as soon as i can.

chrisk

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 51
    • View Profile
    • Donate to Member
Re: SpellWindows Object
« Reply #3 on: March 09, 2006, 09:01:41 AM »
thanks, mouser....will wait patiently.
chrisk