Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 06, 2016, 04:17:18 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Total Commander and Win7  (Read 3675 times)

lanux128

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 6,258
    • View Profile
    • Coding Snacks by Lanux128
    • Read more about this member.
    • Donate to Member
Total Commander and Win7
« on: December 04, 2010, 12:10:08 AM »
i need some help with running totalcmd on Win7 64-bit. this is the scenario: all the files are in the c:\totalcmd folder including the config files (wincmd.ini) but Win7 insists on using the %AppData% folder and refuses to read the settings from the above-mentioned app folder. how can i rectify this? i've already tried running totalcmd as admin but to no avail..

J-Mac

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 2,913
    • View Profile
    • Donate to Member
Re: Total Commander and Win7
« Reply #1 on: December 04, 2010, 01:48:18 AM »
Don’t know - I'm running TC from the default folder - C:\totalcmd - but on Win7 32-bit. Maybe it's different for 64-bit?

Jim

fenixproductions

  • Honorary Member
  • Joined in 2006
  • **
  • Posts: 1,184
    • View Profile
    • Donate to Member
Re: Total Commander and Win7
« Reply #2 on: December 04, 2010, 08:12:08 AM »
@lanux128
Did you try to contact with author on TC forum board?

Either way, maybe this will help you:

Quote from: Help file
[Configuration]
UseIniInProgramDir=0
This variable will only be read if the wincmd.ini is located in the same dir as the program. It must be put in wincmd.ini directly, RedirectSection has no effect on this variable.
It is the sum of the following values:
1: Use wincmd.ini in program dir if no other location is set via registry or parameters
2: Use wcx_ftp.ini in program dir if no other location is set via registry or parameters
4: Override registry settings (but not command line parameters)

Of course, if your TC resides in Program Files directory you will have to set proper acess rights.

MrZebulon

  • Supporting Member
  • Joined in 2008
  • **
  • default avatar
  • Posts: 24
    • View Profile
    • Donate to Member
Re: Total Commander and Win7
« Reply #3 on: December 04, 2010, 01:12:31 PM »
Did you check if the environment variable "COMMANDER_PATH=C:\TotalCommander" (i.e. your path!) is set?

Greetings
« Last Edit: December 04, 2010, 01:14:46 PM by MrZebulon »

lanux128

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 6,258
    • View Profile
    • Coding Snacks by Lanux128
    • Read more about this member.
    • Donate to Member
Re: Total Commander and Win7
« Reply #4 on: December 05, 2010, 10:58:02 PM »
thanks to all for your suggestions.. i'll try them out and see if they work. :)

brahman

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 171
    • View Profile
    • Donate to Member
Re: Total Commander and Win7
« Reply #5 on: December 06, 2010, 03:04:32 PM »
Maybe you can deinstall and then reinstall.

AFAIR when you install, TC will ask you where you want the ini setting file to be.
Regards, Brahman

lanux128

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 6,258
    • View Profile
    • Coding Snacks by Lanux128
    • Read more about this member.
    • Donate to Member
Re: Total Commander and Win7
« Reply #6 on: December 07, 2010, 12:21:02 AM »
thanks fenixproductions! your suggestion worked! i edited the INI file and now it reads from the appdir.

[Configuration]
UseIniInProgramDir=3

thanks again to everyone for your help.. :)