Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • September 01, 2015, 05:18:56 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Icons not showing in LBC  (Read 4012 times)

briandr67

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 29
  • A Software Junky
    • View Profile
    • Donate to Member
Icons not showing in LBC
« on: November 04, 2010, 06:13:33 PM »
Mouser, not sure if this is a bug or not, but LBC does not show the icons of 64bit apps from shortcuts. Before using LBC I made a toolbar from a folder of subfolders of shortcuts. When I setup LBC I used these folders and added a few of my most used programs to the bar. The directly linked 64bit app icon displays correctly, the icon from the shortcut doesn't. See screenshots. My Bar.jpg Folder Tree.jpg Edit: BTW, I am running Win 7 Home Premium X64 on a Dell Inspiron 1545 Notebook
« Last Edit: November 04, 2010, 06:50:28 PM by briandr67 »

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 34,975
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Donate to Member
Re: Icons not showing in LBC
« Reply #1 on: November 05, 2010, 06:35:39 AM »
Ok so just to clarify what you are saying:

1) if you ask LBC to display the contents of a folder in a menu, that has no problems.
2) but if you manually add a button to a LBC bar, and link to a shortcut, it doesn't show the button at all?

just so i fully understand, can you show me your LBC configuration screen where you have selected this button node and it's showing the details of it.

briandr67

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 29
  • A Software Junky
    • View Profile
    • Donate to Member
Re: Icons not showing in LBC
« Reply #2 on: November 05, 2010, 07:58:55 PM »
 Mouser, it shows the icons of all the 32bit apps from their shortcuts in the dropdown lists, but not the icons from 64bit apps. If you look at the dropdown list in the top screenshot above all icons are shown except the xplorer2 icon (xplorer2_64.exe) which I have circled. Node is a Folder Node. If you look further along the bar to the second circled item, the xplorer2 icon shows as it is linked directly to the program file. Node is a Command Node.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 34,975
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Donate to Member
Re: Icons not showing in LBC
« Reply #3 on: November 05, 2010, 08:46:56 PM »
ok im still unclear about what you are saying the behavior is..

i'm sorry for being dense, but am i understanding it now that the problem is that when displaying a drop down menu of folder contents, it is showing the entry for a 64bit app, and can launch it ok, BUT that the icon is wrong/generic ?

i'm pretty sure that's what you are saying now.. yes?

briandr67

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 29
  • A Software Junky
    • View Profile
    • Donate to Member
Re: Icons not showing in LBC
« Reply #4 on: November 05, 2010, 08:59:20 PM »
That is entirely correct Jesse

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 34,975
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Donate to Member
Re: Icons not showing in LBC
« Reply #5 on: November 05, 2010, 09:57:20 PM »
ok, now that i understand i can try to figure out how to fix it..

here's a question for you, if you look at the detailed properties of the xplorer^2 shortcut whose icon isnt displaying properly in windows file explorer right+click context menu for properties, do you see anything unusual about it? does it point to an actual correct location on the disk for the application? any other parameters passed to it? anything unusual at all?

briandr67

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 29
  • A Software Junky
    • View Profile
    • Donate to Member
Re: Icons not showing in LBC
« Reply #6 on: November 05, 2010, 10:13:12 PM »
If you look at the right pane of the screenshot of xplorer 2 above the icon is fine, same in explorer and all my file managers. Nothing unusual at all for any of them. It seems that LBC being 32bit, it can hook the icons from other 32bit app shortcuts, but not 64bit app shortcuts because the same problem occurs with all shortcuts for 64bit apps.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 34,975
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Donate to Member
Re: Icons not showing in LBC
« Reply #7 on: November 05, 2010, 10:14:31 PM »
Quote
because the same problem occurs with all shortcuts for 64bit apps.

ok that's what i wanted to know.

ok let me look into it and see what i can figure out.

but.. actually if you could show me the property dialog for one of these shortcuts, it might help..
is the target path to it exact? or is there some path environmental variable involved?

briandr67

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 29
  • A Software Junky
    • View Profile
    • Donate to Member
Re: Icons not showing in LBC
« Reply #8 on: November 05, 2010, 10:47:19 PM »
No variables whatsoever, path is correct. I have included screenshots of the properties dialogue and the folder proper in Windows Explorer.

briandr67

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 29
  • A Software Junky
    • View Profile
    • Donate to Member
Re: Icons not showing in LBC
« Reply #9 on: November 05, 2010, 11:07:45 PM »
Just to add weight to my theory that LBC is unable to hook icons from shortcuts to x64 apps.......DVD Maker.jpg C:\Program Files\DVD Maker\DVDMaker.exe
MFICMDGUI.jpg C:\Program Files\Microsoft Fix it Center\FixitCenter.exe, C:\Program Files\MyDefragGUI\MyDefragGUI.exe Games.jpg C:\Program Files\Microsoft Games\Mahjong\Mahjong.exe, C:\Program Files\Microsoft Games\Solitaire\Solitaire.exe, Paint.net.jpg C:\Program Files\Paint.NET\PaintDotNet.exe
As you can see all are from the C:\Program Files, 64bit programs folder, not the C:\Program Files (x86) 32bit programs folder.
« Last Edit: November 05, 2010, 11:11:58 PM by briandr67 »

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 34,975
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Donate to Member
Re: Icons not showing in LBC
« Reply #10 on: November 05, 2010, 11:20:19 PM »
yep, ok and the shortcuts are simple normal shortcuts.
i have all i need, now i will try to fix.
thanks for your patience!

briandr67

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 29
  • A Software Junky
    • View Profile
    • Donate to Member
Re: Icons not showing in LBC
« Reply #11 on: November 05, 2010, 11:29:36 PM »
Thanks Jesse for being so gracious in allowing me to be a pain in the butt, pulling you off ya NANY app, and the MozFo game and anything else you're working on. Brian