Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 10, 2016, 04:56:39 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Anyone using Backup4All on Windows 7, please?  (Read 2379 times)

tranglos

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 1,079
    • View Profile
    • Donate to Member
Anyone using Backup4All on Windows 7, please?
« on: August 30, 2010, 04:27:36 PM »
I have a very small request to anyone who might be running Backup4All on Windows 7. It seems that when editing a backup job, I can not drag and drop files onto the "Sources" pane (in the "Backup Properties" dialog). Could you check if this works for you?

Select any backup job, click Properties on the toolbar, then click "Sources". Then drag a file or a folder from your file manager onto the Sources pane. Backup4All should accept the dropped files. Does it? (Also, when you start Backup4All manually, do you get the UAC prompt? I expect these things might be related.)

(On edit: for "any" backup job, read "any standard backup job", where you manually specify source files and folders. It cannot be one of the predefined profiles such as "My Documents" or "Backup4All configuration, etc., because for those you cannot manually add locations anyway.)

It worked fine under XP but no longer works in 7 for me. I posted a support ticket, to which author says nothing has changed and drag-and-drop should still work. So I'm curious if this is an actual bug or something specific to my system.

If you can try the experiment and let me know the results, thanks a lot in advance!
« Last Edit: August 30, 2010, 04:34:31 PM by tranglos »

superboyac

  • Charter Member
  • Joined in 2005
  • ***
  • Posts: 6,070
  • Is your software in my list?
    • View Profile
    • Donate to Member
Re: Anyone using Backup4All on Windows 7, please?
« Reply #1 on: August 30, 2010, 05:00:48 PM »
I'm surprised the developers don't work with you to solve the problem.  Most software developers for non-huge companies would do that.  If I have time, I can check this for you tonight.

tranglos

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 1,079
    • View Profile
    • Donate to Member
Re: Anyone using Backup4All on Windows 7, please?
« Reply #2 on: August 30, 2010, 07:13:55 PM »
Thanks superboyac. I've just had a little idea that confirmed my earlier hunch - it has to do with UAC and elevation. When I run Total Commander as administrator, drag and drop to Backup4All magically returns.

Further explanation here.

(A cheap sarcastic comment about Microsoft elided.)

On edit: I do want to add though that the annoyance of UAC in this case goes beyond just not having drag and drop available. In Backup4All you can click an "Add folder" button to add folders to a backup job, but the folder picker dialog box that opens hides certain folders, as all Explorer windows do. So it becomes almost impossible to add certain important folders to a backup. Thankfully there is an edit box now where you can type or paste a folder path, but it's the least convenient way of all.

This, along with the annoyance known as no-system-wide-hotkeys-when-elevated-app-has-focus, adds up to a serious temptation to disable UAC. Has anyone ever seen a UAC prompt that was not a false positive? One that actually saved you from doing something you'd have regretted?
« Last Edit: August 30, 2010, 07:28:26 PM by tranglos »

barney

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 1,282
    • View Profile
    • Donate to Member
Re: Anyone using Backup4All on Windows 7, please?
« Reply #3 on: August 31, 2010, 10:57:38 PM »
Quote
Has anyone ever seen a UAC prompt that was not a false positive? One that actually saved you from doing something you'd have regretted?
I must say I have yet to see any UAC warning that was anything more than an impediment to whatever I was doing at the time.  It's a nice thought, but a really sucky implementation.

kyrathaba

  • N.A.N.Y. Organizer
  • Honorary Member
  • Joined in 2006
  • **
  • Posts: 3,120
    • View Profile
    • Donate to Member
Re: Anyone using Backup4All on Windows 7, please?
« Reply #4 on: October 12, 2010, 09:58:21 PM »
UAC: good idea in theory; could have been implemented in a more user-friendly fashion.  In a sense, same problem you have with antivirus programs.  The software is choosing to err on the side of caution, but to the end-user it's "Grrrrrr....."