Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • September 04, 2015, 05:27:51 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: CZB Pack - Timer plugin error  (Read 3534 times)

omaedon

  • Participant
  • Joined in 2008
  • *
  • default avatar
  • Posts: 12
    • View Profile
    • Donate to Member
CZB Pack - Timer plugin error
« on: July 13, 2010, 10:19:35 PM »
UPDATE: I fixed the error by deleting the variables related to Timer under Options\User Variables and reloaded the plugin. Timer is now functioning properly.

Whenever I load FARR, I get a bluebox that shows the error message "error occured while loading C:program files\FARR\Plugins\CZB_pack\Timer\fsubscript.js; message: Expected ']' name: SyntaxError

I tried replacing the Timer plugin files in my program files directory with the originals from CZB_pack rar file, but the error still occurred. Anyone experience this error before?
« Last Edit: July 13, 2010, 11:03:10 PM by omaedon »

splitDiff

  • Participant
  • Joined in 2009
  • *
  • Posts: 1
    • View Profile
    • Donate to Member
Re: CZB Pack - Timer plugin error
« Reply #1 on: May 25, 2011, 12:04:38 PM »
UPDATE: I fixed the error by deleting the variables related to Timer under Options\User Variables and reloaded the plugin. Timer is now functioning properly.

Half an hour ago, I got fed up with the JSON.parse error and not being able to use the Timer plugin , so I decided to solve it. Turned out that something messed up my findandrunrobot.ini file and the json there was all messed up. I corrected the code there, and all is fine now.

Cleaning out the UserVars also resolved a JSON parsing error that I was getting in Timer plugin (see Armando's experience as well).

To correct:
  • Halt FARR
  • Locate and open the FindAndRunRobot.ini file
  • Remove the [Timer] section of the [ExtraSettings] UserVars
  • Restart FARR

The JSON parsing error has not reappeared and, most importantly, Timer is working again.

Armando

  • Charter Member
  • Joined in 2005
  • ***
  • Posts: 2,708
    • View Profile
    • Donate to Member
Re: CZB Pack - Timer plugin error
« Reply #2 on: May 25, 2011, 01:02:24 PM »
Hey, so I wasn't the only one! Thanks splitDiff.

This exactly what I did/do too (and sometimes still have to do... Not sure what is causing the JSON problems -- a bug in the parser ?)... but didn't post about it as nobody seemed to care at the time.  :)

The only problem is loosing all settings and needing to re-enter all presets etc.

walbert

  • Supporting Member
  • Joined in 2009
  • **
  • Posts: 2
    • View Profile
    • Donate to Member
Re: CZB Pack - Timer plugin error
« Reply #3 on: November 23, 2011, 10:01:38 AM »
This error popups when i try to set a daily alarm  :(


command used - tm at 11pm repeat 1d do Bedtime
If i remove repeat, it works - tm at 11pm do Bedtime

Any suggestions?