Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • August 31, 2015, 08:56:53 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Last post Author Topic: DONE - IDEA: launch apps on Fast User Switch (set vol., etc).  (Read 25184 times)

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 34,959
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Donate to Member
Re: DONE - IDEA: launch apps on Fast User Switch (set vol., etc).
« Reply #25 on: May 04, 2005, 07:51:37 AM »
you know what would help -
since this program operates so silently, and infrequently, i think it would be useful if it wrote a log file output in same dir as the ini.
like USERNAME.log, which just displayed DATETIME commandlinerun

frogblast

  • Participant
  • Joined in 2005
  • *
  • gravatar avatar
  • Posts: 14
    • View Profile
    • Donate to Member
Re: DONE - IDEA: launch apps on Fast User Switch (set vol., etc).
« Reply #26 on: May 04, 2005, 08:04:26 AM »
After a bit more testing, I realized that RunOnSwitch seems to work fine for me with other command lines; it just doesn't like devcon.exe, or devcon.exe doesn't like it, for some reason. Maybe there's some weird timing issue. I'll try adding a pause before running devcon.exe and see if that helps.

--EDIT--

No, that didn't help. It's perfectly bizarre, because when devcon reports that the mouse is enabled, the mouse is actually disabled, and when it reports the mouse is disabled, the mouse works. Yet when I use devcon to enable/disable the mouse in a normal command window, it works as expected. For some bizarre reason, using devcon with RunOnSwitch causes its effect to be 180 degrees out of phase with what it reports. Any idea why this might be happening?
« Last Edit: May 04, 2005, 08:14:24 AM by frogblast »

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 34,959
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Donate to Member
Re: DONE - IDEA: launch apps on Fast User Switch (set vol., etc).
« Reply #27 on: May 04, 2005, 08:22:38 AM »
that is really strange.. i look forward to hearing the fix/explanation..

Uncle John

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 38
    • View Profile
    • Donate to Member
Re: DONE - IDEA: launch apps on Fast User Switch (set vol., etc).
« Reply #28 on: December 10, 2009, 12:45:15 PM »
Having trouble locating RunonSwitch. Could you please add a link to it from this forum?