Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 10, 2016, 10:41:27 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: How to kill off the "Open File - Security Warning" dialog box  (Read 2194 times)

bumblefoot2004

  • Participant
  • Joined in 2009
  • *
  • Posts: 6
    • View Profile
    • Donate to Member
How to kill off the "Open File - Security Warning" dialog box
« on: October 23, 2009, 12:26:24 PM »
IDEA: I need something that can stop Windows from displaying the "Open File - Security Warning" every time I try to run an .EXE executable file. I clear the "Always ask before opening this file" checkbox so it won't appear again, but it still does. If this can be killed off with a registry setting, please let me know. Here's what I'm talking about:


gexecuter

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 252
  • Move over and give us some room...
    • View Profile
    • Elite Freeware
    • Donate to Member
Re: How to kill off the "Open File - Security Warning" dialog box
« Reply #1 on: October 23, 2009, 07:13:56 PM »
yeah i have that too (in my windows xp home instalation) if you have xp pro there's a method for removing that annoyance tough i don't remember how exactly. so google is your best friend now, use him.
Mouser is made of win and awesome!

tranglos

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 1,079
    • View Profile
    • Donate to Member
Re: How to kill off the "Open File - Security Warning" dialog box
« Reply #2 on: October 23, 2009, 07:30:47 PM »
The setting lives in Internet Explorer: Tools -> Internet Options -> Security. Click "Custom level". About half-way through the very long list in this dialog, under "Miscellaneous", there is a setting like "Launching applications and unsafe files" (I have a Polish version of Windows, not entirely sure about the Englisyh labels). By default this is set to Prompt, so you can change it to "Enable".

Caveat: I don't usually download files through IE, but check to make sure that setting this option to Enable will *not* also mean ie will automatically execute any .exe you click on. (It shouldn't, but check to be safe.)

Ehtyar

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 1,237
    • View Profile
    • Donate to Member
Re: How to kill off the "Open File - Security Warning" dialog box
« Reply #3 on: October 23, 2009, 07:44:01 PM »
If you're using Firefox, you need to enter about:config and create a new boolean preference with the name 'browser.download.manager.skipWinSecurityPolicyChecks' and set it to 'true'.

After some quick searching I was unable to find an appropriate method of disabling the dialog box globally. However, if you're attempting to run the offending executable as part of a script, try setting the 'SEE_MASK_NOZONECHECKS' environment variable to '1' prior to executing the application.

Ehtyar.

lanux128

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 6,258
    • View Profile
    • Coding Snacks by Lanux128
    • Read more about this member.
    • Donate to Member
Re: How to kill off the "Open File - Security Warning" dialog box
« Reply #4 on: October 23, 2009, 10:49:09 PM »
this was asked before but i'm not sure how it was resolved, do check out some of the related threads here..

http://www.donationc...dex.php?topic=5459.0
http://www.donationc...ex.php?topic=17199.0