Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 09, 2016, 11:30:55 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: bug ? :"windows" key not working properly  (Read 2494 times)

valenock

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 2
    • View Profile
    • Donate to Member
bug ? :"windows" key not working properly
« on: June 22, 2009, 03:30:47 PM »
I cannot set any of CHS hotkeys to use the "windows" key.

When I try to set it in options\hotkeys and input "Windows + C" only "ctrl + alt + c" is actually captured. 
It seems to be a bug in key detection routine.

As a "hardcore" Autohotkey user I tried to uncrypt the .ini file itself, but didn't understand the key code:
"HotKeyQuickPaste.HotKey=49219"

In autohotkey itself I would use #c shortcut instead.

Could you please fix the bug or just send me a keycode for # ?

Thanks for the nice program anyway !

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,426
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: bug ? :"windows" key not working properly
« Reply #1 on: June 29, 2009, 08:55:43 AM »
Sorry for the late reply -- this is a limitation of the program currently.. it doesn't know how to detect windows key.
I'll try to add it in for the next version -- it's definitely possible (i did it for one of my other programs) just requires a bit of a workaround.