Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • October 27, 2016, 07:36:43 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: No network adapter available without admin rights  (Read 3029 times)


  • Participant
  • Joined in 2009
  • *
  • Posts: 1
    • View Profile
    • Donate to Member
No network adapter available without admin rights
« on: June 06, 2009, 08:07:15 AM »

as you see in the attached picture I have the problem that I can't choose any network adapter when logged in as a normal user (after reboot). What's kind of strange for me is the fact that in "c:\program files\urlsnooper2\settings.ini" the correct NIC is entered.

System: Win XP Home SP3
URLSnooper2: 2.23.01
Personal FW: none

What I can use as some kind of "workaround" is the following procedure:
Logoff the normal account > login as an admin > start urlsnooper > General Options tab (the network adapter entry is still blank but as an admin the drop down menu shows all of the NICs available) > choose correct NIC > logoff admin > logon normal user

That's quite a nuisance doing it after every reboot but it works and the correct NIC is now available.

What I tried to solve that problem was setting file permissions and/or owner that way that normal users have full access to the files, but this removed only the "can't write user settings blabla" error message.

Any ideas what I can do to solve that problem?

kind regards


  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,339
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: No network adapter available without admin rights
« Reply #1 on: June 06, 2009, 09:39:04 PM »
That is really strange.. i don't quite know how to explain the fact that once you select it in administrator mode, it still works even after you log out and log back in as a normal user..  :o