Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 03, 2016, 01:40:31 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: FARR Unable to launch VirtualBox (and perhaps others) in Win7?  (Read 5274 times)

dandersahn

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 20
    • View Profile
    • Donate to Member
I've been using FARR with Windows 7 x64(both beta and RC) and have noticed that while for the most part it works just fine, there are certain very rare programs that it can't seem to launch.  The only example that I can provide at the moment (because it's the only one that I use enough to remember) is VirtualBox.  I have no idea why, but when I try to launch the VirtualBox Manager using FARR, either nothing happens (if the "Launch Method" is set to "Method 1 - ShellExecute") or Windows tells me that the path to the .lnk file does not exist (if the "Launch Method" is set to "Method 2 - ShellExcuteEx" [SIC]).  Both the path to the shortcut and the executable exist and the shortcut launches just fine using Explorer.  I can't figure out what is different about this program.  I've tried compatibility modes, security settings, etc.  Seems to be something with the path, but I can't figure it out.  Has anyone else seen anything like this?

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,405
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: FARR Unable to launch VirtualBox (and perhaps others) in Win7?
« Reply #1 on: June 02, 2009, 03:46:33 PM »
are there any spaces in the filename?
if you go look at the shortcut file, and right click on it and view properties, is it one of those shortcuts that doesn't link to an actual location?

dandersahn

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 20
    • View Profile
    • Donate to Member
Re: FARR Unable to launch VirtualBox (and perhaps others) in Win7?
« Reply #2 on: June 02, 2009, 07:43:04 PM »
It's a completely normal shortcut with no spaces in the file name.  The path the the exe is:

"C:\Program Files\Sun\VirtualBox\VirtualBox.exe"

It was originally installed in:

"C:\Program Files\Sun\xVM VirtualBox\VirtualBox.exe"

I thought the "\xVM" might be causing a problem as \x is a hex character code escape sequence in Python (and perhaps other languages), but reinstalling in a different directory didn't help.


mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,405
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: FARR Unable to launch VirtualBox (and perhaps others) in Win7?
« Reply #3 on: June 02, 2009, 07:55:05 PM »
thats very strange.. anyone else with virtualbox installed have this problem?

dandersahn

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 20
    • View Profile
    • Donate to Member
Re: FARR Unable to launch VirtualBox (and perhaps others) in Win7?
« Reply #4 on: June 19, 2009, 08:44:18 AM »
Here's another program that does the exact same thing -- Paint.net. The same error is presented: "The specified path does not exist".  The path does exist.  The shortcut works find when launched via Explorer or the start menu.  It's a very standard looking target:

"C:\Program Files\Paint.NET\PaintDotNet.exe"

Only thing remotely notable is the "." in the folder name.



mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,405
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: FARR Unable to launch VirtualBox (and perhaps others) in Win7?
« Reply #5 on: June 19, 2009, 10:20:47 AM »
i wonder if indeed that . is the problem.. care to experiment a little by making copies of the program in dif dirs with and without dots in them?

dandersahn

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 20
    • View Profile
    • Donate to Member
Re: FARR Unable to launch VirtualBox (and perhaps others) in Win7?
« Reply #6 on: June 19, 2009, 01:37:29 PM »
Reinstalled in "C:\Program Files (x86)\PaintDotNET\PaintDotNet.exe".  Still no luck.

dandersahn

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 20
    • View Profile
    • Donate to Member
Re: FARR Unable to launch VirtualBox (and perhaps others) in Win7?
« Reply #7 on: June 19, 2009, 02:12:57 PM »
I figured out something out that is fairly bizarre.  If I view the properties for the shortcut by using the right click context menu from within Explorer, the target shows as...

C:\Program Files\PaintDotNET\PaintDotNet.exe

... which is correct.  BUT if I select "shell context menu" from the FARR context menu and then select properties, the target (for the exact same shortcut file) shows as ...

C:\Program Files (x86)\PaintDotNET\PaintDotNet.exe

So something funky is going on for some 64bit programs.  My workaround is to "Ignore item in the future" and have FARR launch the exe directly instead of the shortcut.  This workaround obviously only works if there are no arguments.  I will try running the program in compatibility modes to see if that helps.

Tekzel

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 228
    • View Profile
    • Donate to Member
Re: FARR Unable to launch VirtualBox (and perhaps others) in Win7?
« Reply #8 on: June 22, 2009, 05:49:10 PM »
I have had a similar issue, Win7 RC1 x64 and the one I notice this on is Q-Dir 64bit.  I just figured it was the fact that it was a 64bit program and that had something do with it.  Can't think of any others off hand, but I know I have the issue with at least one other program.

dandersahn

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 20
    • View Profile
    • Donate to Member
Re: FARR Unable to launch VirtualBox (and perhaps others) in Win7?
« Reply #9 on: June 22, 2009, 06:40:45 PM »
I have found that if you change the path by opening the shortcut properties through the FARR (1-right click on the shortcut within the FARR results, 2-"shell context menu", 3-"properties") it will fix the problem.  It's almost as if somehow the shortcut is storing two values - one for 64bit Explorer and one for 32bit FARR.

Tekzel

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 228
    • View Profile
    • Donate to Member
Re: FARR Unable to launch VirtualBox (and perhaps others) in Win7?
« Reply #10 on: June 23, 2009, 10:27:46 AM »
I have found that if you change the path by opening the shortcut properties through the FARR (1-right click on the shortcut within the FARR results, 2-"shell context menu", 3-"properties") it will fix the problem.  It's almost as if somehow the shortcut is storing two values - one for 64bit Explorer and one for 32bit FARR.

Hah, I never even thought to check that, but when I did it for giggles I found that the .lnk FARR was running actually pointed to the PF (x86) folder, and I have the 64bit version installed.  Weird that I didn't get any "File or object not found" kind of message.  Oh well, when I updated the target in the shortcut it works fine now.  Going to keep that one in mind when I run into any other similar issues.