Welcome Guest.   Make a donation to an author on the site September 01, 2014, 06:31:36 AM  *

Please login or register.
Or did you miss your validation email?


Login with username and password (forgot your password?)
Why not become a lifetime supporting member of the site with a one-time donation of any amount? Your donation entitles you to a ton of additional benefits, including access to exclusive discounts and downloads, the ability to enter monthly free software drawings, and a single non-expiring license key for all of our programs.


You must sign up here before you can post and access some areas of the site. Registration is totally free and confidential.
 
Check out and download the GOE 2007 Freeware Challenge productivity tools.
   
   Forum Home   Thread Marks Chat! Downloads Search Login Register  
Pages: [1]   Go Down
  Reply  |  New Topic  |  Print  
Author Topic: How to get my sound back without having to reboot  (Read 3995 times)
patteo
Charter Member
***
Posts: 436


View Profile Read user's biography. Give some DonationCredits to this forum member
« on: April 18, 2009, 12:42:20 AM »

Every now and then, when my laptop wakes up from standby, I will find that the sound does not work. The frustrating thing is that I may have been listening to an audio just before putting the laptop on standby.

I would then check the hardware device drivers (under Device Manager. properties) and find that it appears that the sound hardware is properly enabled. Or the messge on the General Tab of properties for that driver will say "This device is working properly"

And the only way I found to fix it so far is a "Reboot."

But of course that is rather time consuming.

Has anyone found a way to fix a problem like that without rebooting ?

I'm using
Lenovo Thinkpad T8100
2GB Ram
Windows XP SP3
Device Drive is Soundmax HD Audio
« Last Edit: April 18, 2009, 01:58:18 AM by patteo » Logged
app103
That scary taskbar girl
Global Moderator
*****
Posts: 5,178



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #1 on: April 18, 2009, 12:45:51 AM »

First I would check to make sure you have the most up to date drivers for your soundcard.

If that doesn't fix the issue, it might be like the issue I had on my HP, which I was able to "fix" without rebooting by simply plugging in a set of earphones and then unplugging them.
Logged

lanux128
Global Moderator
*****
Posts: 6,088



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #2 on: April 18, 2009, 01:34:10 AM »

Has anyone found a way to fix a problem like that without rebooting ?

you didn't say anything about your OS or your audio drivers but i usually have this problem with Realtek. my workaround is to enable the "Enable auto pop-up dialog when device has been plugged in" option within Realtek's Sound Effect Manager, see screenshot for more details. so when your PC comes back from standby, you can just click 'OK' on the message box that pops-up and your sound should work.



Logged

patteo
Charter Member
***
Posts: 436


View Profile Read user's biography. Give some DonationCredits to this forum member
« Reply #3 on: April 18, 2009, 02:04:07 AM »

you didn't say anything about your OS or your audio drivers but i usually have this problem with Realtek. my workaround is to enable the "Enable auto pop-up dialog when device has been plugged in" option within Realtek's Sound Effect Manager, see screenshot for more details. so when your PC comes back from standby, you can just click 'OK' on the message box that pops-up and your sound should work.
 (see attachment in previous post)


I have updated details of my OS and sound drivers.

Unfortunately, my drivers doesn't come bundle with additional sound software or at least I don't see any around.

I'm beginning to think that it may have something to do with my ear piece being plugged into the audio jacks when I put it into standby.

So I think I may just try to unplug them just before I go into standby and see if that sort of solves the problem.

Thanks for the posts App103 and Lanux128
Logged
lanux128
Global Moderator
*****
Posts: 6,088



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #4 on: April 18, 2009, 02:35:42 AM »

Unfortunately, my drivers doesn't come bundle with additional sound software or at least I don't see any around.

I'm beginning to think that it may have something to do with my ear piece being plugged into the audio jacks when I put it into standby.

So I think I may just try to unplug them just before I go into standby and see if that sort of solves the problem

to check if Soundmax comes with any additional software, look for folders like: 'c:\drivers\audio' or 'C:\Program Files\Soundmax' but i guess you would have done that already. smiley

some googling also returned this thread where this problem have been prevalent. so if the ear-piece thing doesn't work out, you may have to log a problem with lenovo..



Logged

app103
That scary taskbar girl
Global Moderator
*****
Posts: 5,178



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #5 on: April 18, 2009, 02:44:04 AM »

you didn't say anything about your OS or your audio drivers but i usually have this problem with Realtek.

Realtek was what I had problems with on my HP. It was misdetecting whether I had a set of earphones plugged in or not and switching modes on me. Enabling that autopopup made it happen more frequently, so I had to disable that.

I'd have to force it to correct itself by actually plugging something in and then unplugging it, forcing it to switch to the correct mode. Funny thing is that was usually the only time I ever plugged in a set of earphones. I didn't have any other use for them except as a Realtek fixing tool.

I'm beginning to think that it may have something to do with my ear piece being plugged into the audio jacks when I put it into standby.

So I think I may just try to unplug them just before I go into standby and see if that sort of solves the problem.

If that works and you forget to unplug them, or that doesn't work, just try what I said, plugging the earphones in & out a few times, because you might be having the same problem I had.

You also said you may have been listening to an audio just before putting the laptop in standby. You didn't say what format of audio or with what software.

I had some sort of codec clash on my old pc when using audio in teamspeak. Everything worked fine in both teamspeak and my whole OS, until I closed that application. Then I would lose all sound till I rebooted. As long as I didn't close teamspeak till I was ready to reboot any way, I didn't have a problem. (that's why I have always hated using teamspeak)

So test whether it's related to running that audio application or with a specific file format first, before you go into standby. Close that application and make sure you still have sound elsewhere (just click the little lever on the Windows volume control to make that little "ding" sound). If you don't have sound, then I would say you have narrowed down the source of problem considerably, and it has nothing to do with going into standby.  Wink

If everything still works fine, then try making sure whatever application you use to play audio files is closed before going into standby and see if that helps.
Logged

Pages: [1]   Go Up
  Reply  |  New Topic  |  Print  
 
Jump to:  
   Forum Home   Thread Marks Chat! Downloads Search Login Register  

DonationCoder.com | About Us
DonationCoder.com Forum | Powered by SMF
[ Page time: 0.035s | Server load: 0.1 ]