Welcome Guest.   Make a donation to an author on the site September 01, 2014, 04:27:46 PM  *

Please login or register.
Or did you miss your validation email?


Login with username and password (forgot your password?)
Why not become a lifetime supporting member of the site with a one-time donation of any amount? Your donation entitles you to a ton of additional benefits, including access to exclusive discounts and downloads, the ability to enter monthly free software drawings, and a single non-expiring license key for all of our programs.


You must sign up here before you can post and access some areas of the site. Registration is totally free and confidential.
 
The N.A.N.Y. Challenge 2014! Download dozens of custom programs!
   
   Forum Home   Thread Marks Chat! Downloads Search Login Register  
Pages: [1]   Go Down
  Reply  |  New Topic  |  Print  
Author Topic: Playing Grim Fandango on a modern PC  (Read 9271 times)
lanux128
Global Moderator
*****
Posts: 6,088



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« on: April 09, 2009, 12:02:17 AM »

on a slow day, i tried installing an old favourite just to see if it will run on my WinXP SP3 with 8600GT. everything went well except for sprites which looks 'striped' like in the screenshot. Manny Calavera looks like he's been through a shredder. ohmy

i googled but most of the advices are about setting Win98-compatibility, copying files to the hard-disk and disabling the multiprocessor/hyperthreading settings. i believe my problem is graphics-related and was wondering if anyone else has had any luck with other golden oldies and therefore may lend a hand here.. btw, i had also fiddled with the anti-alias setting (plus some others as well) within nvidia's control panel but to no avail.




Logged

Deozaan
Charter Member
***
Posts: 6,329



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #1 on: April 09, 2009, 01:59:27 AM »

I'm not sure if this would even help, but did you try DOS Box?
Logged

lanux128
Global Moderator
*****
Posts: 6,088



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #2 on: April 09, 2009, 05:49:57 AM »

i thought of DOSBox also but this is a win32 game so there's not much DOSBox can do, i guess..
Logged

Ampa
Charter Member
***
Posts: 589


I am cute ;)

View Profile WWW Give some DonationCredits to this forum member
« Reply #3 on: April 09, 2009, 07:13:16 AM »

It is related to the nVidia drivers and anti-aliasing, but it seems that the newer drviers simply aren't compatible.

Your only options would be to run it in software mode (rather than hardware acceleration), or to install some old nVidia drivers that use the old antialiasing technique.
Logged
lanux128
Global Moderator
*****
Posts: 6,088



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #4 on: April 09, 2009, 08:05:02 AM »

Your only options would be to run it in software mode (rather than hardware acceleration), or to install some old nVidia drivers that use the old antialiasing technique.

thanks, software mode makes it even worse (see pic) but i may have found a solution by disabling hardware acceleration from within DXDiag but its quite cumbersome to disable each time. huh




Logged

Lashiec
Member
**
Posts: 2,374


see users location on a map View Profile Give some DonationCredits to this forum member
« Reply #5 on: April 12, 2009, 06:40:07 PM »

If it's related to antialiasing, perhaps you can create a profile for Grim Fandango in the control panel for nVidia drivers with the option to not use antialiasing at all, if such thing is possible.
Logged
lanux128
Global Moderator
*****
Posts: 6,088



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #6 on: April 12, 2009, 07:39:35 PM »

sorry it might not be clear in the OP but i already tried a creating a profile and fiddled a bit with the settings but was unsuccessful. right now, i'm manually turning off 'DirectDraw' (from the dxdiag applet) before playing to which the game responds better than changing to 'software' mode within the game..



edit: fixed typo and added screenshot.
« Last Edit: April 12, 2009, 08:14:38 PM by lanux128 » Logged

f0dder
Charter Honorary Member
***
Posts: 8,774



[Well, THAT escalated quickly!]

see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #7 on: April 12, 2009, 07:41:34 PM »

FWIW: the corrupted screenshots you posted don't look much like the bug I fixed in the XCOM games. There's both a DirectDraw and an accelerated (D3D?) version?
Logged

- carpe noctem
lanux128
Global Moderator
*****
Posts: 6,088



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #8 on: April 12, 2009, 08:05:22 PM »

AFAIK there is only one version, hardware support (D3D) was already incorporated within the engine (maybe SCUMM). if i enable 'hardware acceleration' the sprites are corrupted as in the OP but software mode introduces horizontal scanning lines as in the 2nd screenshot.

just remembered that later on there was a patch but it was more to fixing in-game bugs..
Logged

lanux128
Global Moderator
*****
Posts: 6,088



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #9 on: April 12, 2009, 08:19:45 PM »

from this thread here, there's a user who explains the problem quite clearly, i must say..

Quote from: Just
Edit: I should have mentioned, both Grim Fandango and Quake 3 used to play fine for me on XP. Since I'd last played them, I've updated my graphics card to an 8800 GTS, though, so I assume that's caused both these games to stop working. On my old graphics card, Quake 3 would play fine out the box, and Grim Fandango would play as long as I used dxdiag to turn off 3D acceleration. But this is one of those things that seems to vary considerably from machine to machine, depending on what hardware you're running. Damn Nvidia drivers...

Source: http://forums.whirlpool.n...&r=16260690#r16260690
Logged

lanux128
Global Moderator
*****
Posts: 6,088



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #10 on: April 19, 2009, 08:41:56 AM »

after some time playing Grim Fandango with disabled hardware acceleration, i must say that i'm quite happy with the performance and the graphics quality. i wrote this program to toggle that setting before and after the game so that i don't have to do it manually each time. so i'm putting up Grim DirectDraw Fix (GrimDDFix) for download in case someone like me has a need for it. happy gaming Wink




* GrimDDFix.zip (226.7 KB - downloaded 2695 times.)
Logged

Pages: [1]   Go Up
  Reply  |  New Topic  |  Print  
 
Jump to:  
   Forum Home   Thread Marks Chat! Downloads Search Login Register  

DonationCoder.com | About Us
DonationCoder.com Forum | Powered by SMF
[ Page time: 0.038s | Server load: 0.16 ]