Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 05, 2016, 02:36:25 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Eight FARR Plugins Are Failing on DCUpdater  (Read 6929 times)

J-Mac

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 2,913
    • View Profile
    • Donate to Member
Eight FARR Plugins Are Failing on DCUpdater
« on: March 17, 2009, 11:22:33 PM »
mouser,

The same eight FARR plugins have been showing as "Get Update Failed" in the Status column of DcUpdater for the last several weeks:

1 Character Table
2 Console
3 Definr
4 Dicts-Thesaurus
5 G-Cal quicadd
6 Google Translator
7 Pop Quotes
8 Timer

You might want to look into this as there has been more than one FARR update since this started, and these plugins might not be working well.

Jim

Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Points: 1
  • Posts: 7,713
    • View Profile
    • The Blog of Deozaan
    • Read more about this member.
    • Donate to Member
Re: Eight FARR Plugins Are Failing on DCUpdater
« Reply #1 on: March 18, 2009, 12:23:48 AM »
That's because they've all been moved into one nice convenient package.

CZB Package


J-Mac

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 2,913
    • View Profile
    • Donate to Member
Re: Eight FARR Plugins Are Failing on DCUpdater
« Reply #2 on: March 18, 2009, 12:44:38 AM »
That's because they've all been moved into one nice convenient package.

CZB Package

Well that's nice, but how was I to know?  :huh:   I have come to rely on DCUpdater to update FARR and all of its plugins. It never offered such a package. And I never noticed that they were "replaced" by that. Hopefully it has not become a requirement to scour the forum for such changes?

Thank you.

Jim

J-Mac

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 2,913
    • View Profile
    • Donate to Member
Re: Eight FARR Plugins Are Failing on DCUpdater
« Reply #3 on: March 18, 2009, 12:49:32 AM »
On second thought, can I just remove the plugins that aren't updated anymore? I don't think I want to hunt for the updates.

Thanks!

Jim

Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Points: 1
  • Posts: 7,713
    • View Profile
    • The Blog of Deozaan
    • Read more about this member.
    • Donate to Member
Re: Eight FARR Plugins Are Failing on DCUpdater
« Reply #4 on: March 18, 2009, 12:50:42 AM »
That's because they've all been moved into one nice convenient package.

CZB Package

Well that's nice, but how was I to know?

Yeah, it's something I had to figure out for myself. I noticed they were all CZB's FARR plugins that were broken and remembered about his NANY submission, so I was able to find it.

I suppose you could also have right clicked them in DcUpdater and selected "Visit package website" to look for updates/fixes.

I'm not so sure on how FARR plugins usually work, but I think I had to manually remove all of CZB's plugins (or at least their .dcupdate files) so that the CZB Package wouldn't interfere with them.


Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Points: 1
  • Posts: 7,713
    • View Profile
    • The Blog of Deozaan
    • Read more about this member.
    • Donate to Member
Re: Eight FARR Plugins Are Failing on DCUpdater
« Reply #5 on: March 18, 2009, 12:51:47 AM »
On second thought, can I just remove the plugins that aren't updated anymore? I don't think I want to hunt for the updates.

Thanks!

Jim

They're still updated, but only as one package, instead of individual plugins. Remove them and/or their .dcupdate files and install the CZB Package and you'll have it all working again properly.


czb

  • Honorary Member
  • Joined in 2007
  • **
  • Posts: 336
    • View Profile
    • My open-source online piano game
    • Donate to Member
Re: Eight FARR Plugins Are Failing on DCUpdater
« Reply #6 on: March 18, 2009, 01:28:34 AM »
Thanks for pointing out.

I have to tell mouser to update the dc update list. It would also be nice if there was an option in DCupdater to warn user that the plugin has been discontinued and where to find the latest one.

PS: My pages are still incorrect too but I will modify them soon
My open-source online piano game: https://github.com/musicope/game

J-Mac

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 2,913
    • View Profile
    • Donate to Member
Re: Eight FARR Plugins Are Failing on DCUpdater
« Reply #7 on: March 18, 2009, 02:28:20 AM »
czb,

I wasn't whining about how it is done; that's not why I said I'm removing them. I don't use a lot of FARR's plugins - only a few, actually. I mostly just launch programs with FARR. I've never taken the time to figure out how to use FARR for other types of searching. It's just easier for me to get them out of FARR because chasing down updates isn't really worth the effort for me.

Thanks!

Jim

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Eight FARR Plugins Are Failing on DCUpdater
« Reply #8 on: March 18, 2009, 04:50:18 AM »
Quote
It would also be nice if there was an option in DCupdater to warn user that the plugin has been discontinued and where to find the latest one.

very good point, added to todo list.

sosimple

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 24
    • View Profile
    • Donate to Member
Re: Eight FARR Plugins Are Failing on DCUpdater
« Reply #9 on: April 01, 2009, 11:26:30 AM »
It seems like the suggestion is to remove the FARR plugins
that are shown in the list above, and install the CZB Package
in their place. I assume it should be done in that order.

What is the best way to remove the plugins? I assume I
should stop FARR, then should I just delete the plugins from
the "Program Files/..." folder ? Or, is there an un-install to
perform ?

I guess it would not be reasonable to expect that installing
the CZB Package would automatically do the necessary
un-install actions.

Kevin