Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 04, 2016, 04:33:48 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Having Trouble in combination with another script (eggdrop)  (Read 10287 times)

Test0r

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 10
    • View Profile
    • Donate to Member
Having Trouble in combination with another script (eggdrop)
« on: March 01, 2009, 10:21:39 AM »
Hi,

i have (hopefully a small) problem here:

I have a server runnig with eggdrop and a few scripts on it.

Actually i have sucessfully installed & configured Mircryption, but there is just one point not running.

- If a user/chatter is posting a command (without having the right encryption key on) for a script - nothing happens -> thats fine!

- But on the server is runnig a script, wich is reading the logfile of the server and is posting this to my channel.
The Content of the LogFile is plaintext and also delivered as plaintext to my channel.

- Then this happens:
This text is posted, but as a decrypted Text -  unfortunately also with a unknown key oO

I have checked the config-files , but found nothing ... i do also changed the order of the scripts in my eggdrop.conf

I just want to see the text, but also in crypted form with my key i just defined in the config-file.

So actuall the text is posted, but with an encryption nobody can read :(

anybody here? who may can help me!?

(Answers also welcome in german ;) )
« Last Edit: March 01, 2009, 10:23:24 AM by Test0r »

Test0r

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 10
    • View Profile
    • Donate to Member
Re: Having Trouble in combination with another script (eggdrop)
« Reply #1 on: March 02, 2009, 11:06:48 AM »
It's annoying.

If i use a command from this script, the output/answer is posted in crypted form with my defined key.

If this script is posting (e.g. a change on the server) themself (without a command from any user), then this output is displayed in crypted form but with another key, so nobody can read :(


Both methods catching/searching their answers from the same log-file  :-\ :huh:

need help  :D
« Last Edit: March 02, 2009, 11:08:25 AM by Test0r »

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Having Trouble in combination with another script (eggdrop)
« Reply #2 on: March 02, 2009, 11:13:58 AM »
i'm not quite sure i understand what is going on..
are you saying that the script is itself encrypting stuff using the wrong key
or are you saying that when someone types using an encrypted key that the server doesn't know, the server repeats it and so no one can read it.

Test0r

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 10
    • View Profile
    • Donate to Member
Re: Having Trouble in combination with another script (eggdrop)
« Reply #3 on: March 02, 2009, 03:59:18 PM »
ok, i will try to explain my problem with an example:

I have a Server:
- on the server is running an eggdrop with 2 scripts
- 1st script = Mircryption
- 2nd script = weather script

If you join my Channel first of all you need is the correct key, or nothing will happen if you type "!weather zipcode".

If you have the right key und type "!weather zipcode" the bot check the logfile und posting the information he found

(in crypted form - using the defined key)

That's all good :) !

BUT

This script is also posting regular stats to the channel itself (e.g. favourite zipcode or so - every 5 hours) -

without any !* command, just itself.
But now something strange happens. Every user (wherever using the right key, another or no key) on the channel see a

posting from the bot. But nobody can read, cause the stats are posted in crypted form with an unknow key (maybe a

random key or so - i dont know :( )

So why is it so?  :-\
« Last Edit: March 02, 2009, 05:41:50 PM by Test0r »

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Having Trouble in combination with another script (eggdrop)
« Reply #4 on: March 02, 2009, 08:29:53 PM »
ok thats clearer now.

in your tcleggdrop_mcps_sitesettings.ini file
have you set a value for default encryption key?

in other words have you removed the # commenting out this line:
#set mcpskey(defaulte)

that might be one way it could happen.

Test0r

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 10
    • View Profile
    • Donate to Member
Re: Having Trouble in combination with another script (eggdrop)
« Reply #5 on: March 03, 2009, 01:15:26 AM »
Hi, here is the ini-file.
These commands are all activated.

#my_channel = i've put in my channel
my_key = i've put in my channel key

set mcpskey(#my_channell) "my_key"


set mcpsprefix(#my_channel) "!"


set mcpskey(defaultd) "my_key"
set mcpskey(defaulte) "my_key"

set mcreplyonlyinkind "false"

set mcreplyneverplaintext "false"

set mcdontlistentoplaintext "false"

set mcmeowreply "true"


set mcautomagic "true"


set mcencryptnick "true"


set mcmaxlinelen 275


Test0r

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 10
    • View Profile
    • Donate to Member
Re: Having Trouble in combination with another script (eggdrop)
« Reply #6 on: March 05, 2009, 05:32:47 AM »
hmm.. no solution aviable :( ?

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Having Trouble in combination with another script (eggdrop)
« Reply #7 on: March 05, 2009, 05:38:00 AM »
can you try disabling (put a # in front of) the lines:
set mcpskey(defaultd) "my_key"
set mcpskey(defaulte) "my_key"

and set keys ONLY for the channels you care about.

Test0r

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 10
    • View Profile
    • Donate to Member
Re: Having Trouble in combination with another script (eggdrop)
« Reply #8 on: March 05, 2009, 06:30:42 AM »
the same as before  :(

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Having Trouble in combination with another script (eggdrop)
« Reply #9 on: March 05, 2009, 06:33:09 AM »
if you disable your channel specific encryption key lines, does the problem go away?

Test0r

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 10
    • View Profile
    • Donate to Member
Re: Having Trouble in combination with another script (eggdrop)
« Reply #10 on: March 05, 2009, 06:46:04 AM »
Sorry, this was wrong...just a moment

#######################################################################################

Ok here the (real) results:

if i disable this line:

set mcpskey(#my_channell) "my_key"

and enable these 2

set mcpskey(defaultd) "my_key"
set mcpskey(defaulte) "my_key"


Result:

Using command "!weather" , the bot answers in crypted form - using the right key.

Any posting by the bot itself, the text is not readable. The bot is not using the right key, but he is using a key  :-\

Example:
Quote
K3xbH.ma54M.vxwkE.iPhAg0Ti3Du1QmMn.16qqEp1VyvUy1L2m.T0nhNpx.OWKW5.vqHwM1YIMLu.j8fMF0X.MJC0WssQ8.

\edit> Hm, now the posted text is right, but still through  :huh:
« Last Edit: March 05, 2009, 06:59:25 AM by Test0r »

Test0r

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 10
    • View Profile
    • Donate to Member
Re: Having Trouble in combination with another script (eggdrop)
« Reply #11 on: March 05, 2009, 08:17:48 AM »
...

maybe i have to change something in plaintextblock?
« Last Edit: March 05, 2009, 08:41:12 AM by Test0r »

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Having Trouble in combination with another script (eggdrop)
« Reply #12 on: March 05, 2009, 09:08:51 AM »
try not using plaintext block script at all, just to make sure it isn't to blame.

Test0r

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 10
    • View Profile
    • Donate to Member
Re: Having Trouble in combination with another script (eggdrop)
« Reply #13 on: March 05, 2009, 12:16:22 PM »
If i set

set mcdontlistentoplaintext "true"

the follwing post will come from the bot:
"eggdrop reply blocked since command was issued in plaintext; this bot only responds to encrypted commands."

But in the explanation stands:
"the mcreplyneverplaintext variable will use a default key, if available, to send replies to all users,
  in order to avoid sending them plaintext."

I have set default-key. But nothing happend...why? :huh:

#edit:

In Plaintextbloxk.tcl stands:

"You can place other scripts below PlaintextBlock.tcl to prevent their
     plaintext from being blocked."


HOW? :D
« Last Edit: March 05, 2009, 12:47:22 PM by Test0r »

Test0r

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 10
    • View Profile
    • Donate to Member
Re: Having Trouble in combination with another script (eggdrop)
« Reply #14 on: March 05, 2009, 01:04:57 PM »
The crypted text - posted from the bot itself (with the unknown key >:( )  begins everytime with "!"..why?

"! K3xbH.ma54M.Xh5UJ.g9ikx03kX9t0BM5yn06qqEp1VyvUy1oJNb908UO581HlMNc.zusqJ/a9KSe0ohWOi/.FEi5.v8Fer/"

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Having Trouble in combination with another script (eggdrop)
« Reply #15 on: March 05, 2009, 01:33:17 PM »
why don't you join #donationcoder on efnet and i can see if i can help you more, it's hard to do this over the forum.