Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 10, 2016, 02:37:47 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Updating xmplay screwed up something BIG! (issue fixed)  (Read 2521 times)

brotherS

  • Master of Good Ideas
  • Honorary Member
  • Joined in 2005
  • **
  • Posts: 2,136
    • View Profile
    • Donate to Member
Updating xmplay screwed up something BIG! (issue fixed)
« on: February 18, 2009, 05:25:41 PM »
Hi,

updating xmplay earlier today had some nasty side-effect: all .exe files (of *all* programs installed) now have a xmplay icon, and the "type" changed to "XMPlay-able file". So when I now try to run a program by clicking an .exe file, it will only bring xmplay to the foreground... SUCKS!

I didn't yet PANIC because the installed programs are still starting when I double-click an associated file, for example .avi -> Zoom Player - so at least nothing important seems to have been overwritten. But how do I change this back so I could again start program directly?!? I use Vista.

Thanks in advance!

« Last Edit: February 22, 2009, 04:09:07 PM by brotherS »

Ehtyar

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 1,237
    • View Profile
    • Donate to Member
Re: WTF! Updating xmplay screwed up something BIG!
« Reply #1 on: February 19, 2009, 04:05:53 AM »
WinHelpOnline have a fix for Vista here. It's simply that XMPlay thought for some reason that it could play .exe files and when you told it to associate itself with the formats it could play, it overwrote the .exe association, a very well know flaw in Windows.

Hope this helps, Ehtyar.

brotherS

  • Master of Good Ideas
  • Honorary Member
  • Joined in 2005
  • **
  • Posts: 2,136
    • View Profile
    • Donate to Member
Re: WTF! Updating xmplay screwed up something BIG!
« Reply #2 on: February 19, 2009, 04:26:13 AM »
WinHelpOnline have a fix for Vista here. It's simply that XMPlay thought for some reason that it could play .exe files and when you told it to associate itself with the formats it could play, it overwrote the .exe association, a very well know flaw in Windows.

Hope this helps, Ehtyar.
Oh, wow, I never heard about something like that happening.

I tried to grab that, but got:
Quote
Forbidden

You don't have permission to access /fileasso/exefix_vista.zip on this server.
Found it on http://winvistaforum...ile-association.html then.

Thanks!

Now clicking programs works again, they just still all have the xmplay icon. Not sure if that could be fixed easily too?
« Last Edit: February 19, 2009, 04:50:45 AM by brotherS »

brotherS

  • Master of Good Ideas
  • Honorary Member
  • Joined in 2005
  • **
  • Posts: 2,136
    • View Profile
    • Donate to Member
Re: Updating xmplay screwed up something BIG! (issue fixed)
« Reply #3 on: February 22, 2009, 04:07:50 PM »
Now clicking programs works again, they just still all have the xmplay icon. Not sure if that could be fixed easily too?
Thankfully, the "all exe icons are incorrect" problem fixed itself just now when I installed a totally not related program, and I didn't even have to reboot since the problem showed up! No idea why or how, but I like THAT it's fixed. 8)

Thanks again for your help!  :Thmbsup:
« Last Edit: February 22, 2009, 04:09:59 PM by brotherS »