Welcome Guest.   Make a donation to an author on the site August 20, 2014, 01:31:21 PM  *

Please login or register.
Or did you miss your validation email?


Login with username and password (forgot your password?)
Why not become a lifetime supporting member of the site with a one-time donation of any amount? Your donation entitles you to a ton of additional benefits, including access to exclusive discounts and downloads, the ability to enter monthly free software drawings, and a single non-expiring license key for all of our programs.


You must sign up here before you can post and access some areas of the site. Registration is totally free and confidential.
 
Check out and download the GOE 2007 Freeware Challenge productivity tools.
   
   Forum Home   Thread Marks Chat! Downloads Search Login Register  
Pages: [1]   Go Down
  Reply  |  New Topic  |  Print  
Author Topic: Scandinavian characters not shown correctly with blowssi  (Read 4303 times)
Pinqvin
Participant
*
Posts: 2

View Profile Give some DonationCredits to this forum member
« on: January 14, 2009, 04:26:28 PM »

I'm having a small problem with irssi and the encryption/decryption plugin blowssi. When I send messages I can see my scandinavian letters (ÀâΓ₯) correctly, but when someone else sends encrypted messages, the characters aren't displayed correctly (instead, it shows a question mark sign). Without encryption I can see all the characters correctly (tested with the same person). Besides the ΓΆΓ€Γ₯ characters I can see the decrypted messages just fine.

Any idea how to fix this? I have all the required dependencies installed, I'm running Arch Linux with 2.6.27-ARCH kernel and I'm on a 64bit installation. Irssi version is 0.8.12 and blowssi is 0.0.2 or the latest available (at least on the official site).
Logged
Gothi[c]
DC Server Admin
Charter Honorary Member
***
Posts: 855



see users location on a map View Profile WWW Give some DonationCredits to this forum member
« Reply #1 on: January 14, 2009, 05:57:37 PM »

I'm pretty sure that's my fault smiley I'll look into it somewhen, when I've got time... You'll also find that it's not encrypting /me and private messages and stuff.. It needs more work smiley
(I'll gladly accept patches from anyone with more time to fix these things cheesy)

For now, maybe juse use aa,oe,ae,etc.. instead smiley
Logged
Pinqvin
Participant
*
Posts: 2

View Profile Give some DonationCredits to this forum member
« Reply #2 on: January 15, 2009, 01:00:39 AM »

Heh, too bad I'm no good with perl nor encryption stuff. The funny thing is that my friend can see all my letters clearly but the ÀâΓ₯'s he sends aren't shown correctly.
« Last Edit: January 15, 2009, 07:57:39 AM by Pinqvin » Logged
Pages: [1]   Go Up
  Reply  |  New Topic  |  Print  
 
Jump to:  
   Forum Home   Thread Marks Chat! Downloads Search Login Register  

DonationCoder.com | About Us
DonationCoder.com Forum | Powered by SMF
[ Page time: 0.031s | Server load: 0.15 ]