Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 07, 2016, 04:40:25 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Spooler SubSystem App has stopped working  (Read 3320 times)

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 7,091
    • View Profile
    • Donate to Member
Spooler SubSystem App has stopped working
« on: December 07, 2008, 06:02:05 AM »
moved from another thread:
---

... I have upgraded ($20) from novaPDF Pro 5.5 to their brand new version Pro 6 - and it is was causing me a lot of troubles!!

As far as I (don't) understand, Vista has this bad habit of making Spooler SubSystem App stop working, when you have installed a virtual printer. At least, I have frequently been the victim of this error. But when I upgraded from novaPDF 5.5 to version 6, the problem got a lot worse: Every time I clicked "Print", Firefox would crash!! Internet Explorer 7 had no problems, though. So I used this temporary fix, I've found online:

Quote
I had "spooler subsystem app stopped working..." and found solution that may help you to fix your case.

I don't know some how vista turn off LDP port after installing new printer driver and leaves only Internet client port only. That why the printer spooler service failed to start. Solution is:

1. Go to Programs and Features in Control panel > click Turn Windows features on or off

2. click + sign of Print services

3. Select LPD and LPR. You should remove Internet Printing Client. > restart your PC to ensure there is no error of spooler service.

4. Add your printer driver again.

It worked for me.

It kind of worked for me as well. Firefox will print, and all is nice, and novaPDF Pro 6 is so clever and can do all sorts of things (it can even "add to existing file"! thumbs up, this is such a fine feature!) - but now Internet Explorer has stopped working!!! Personally I don't mind, I don't use IE any more, but it goes to show that the fix not is a wonder-fix or without problems. Maybe it all is about what Lashiec also wrote about on another thread:

... Those extras are those things pertaining to Vista features, like the printing system. As you know, Microsoft developed a new printing subsystem, that uses XML-based files for the spooler. The guys said: "hey, considering that this is, essentially, a readable file, what if we do a new format based on it?" And thus came XPS. Microsoft did something similar with the printing subsystem prior Vista, and those spool files were the basis for the dreadful WMF pictures. Well, .NET includes XPS reader and printer to produce your own XPS files and challenge Adobe and PDF ;D. They introduce that without asking, but then they are always saying they can't make DirectX10 for XP because of architectural changes, and bla, bla, bla...

Maybe I really didn't ask a question, but do "you" have any comments?
 :tellme:
« Last Edit: December 07, 2008, 06:08:24 AM by Curt »