Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • September 03, 2015, 02:14:05 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: [Bug report] Farr freezing on XP for a few minute, then comes back  (Read 3751 times)

jaden

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 145
    • View Profile
    • My blog
    • Donate to Member
After upgrading to 2.07.01, FARR regularly (several times a day) hangs just after I launch an application, or when I'm closing the options dialog.  I'd estimate it's once every 5-10 times.  There's still activity going on when it's unresponsive - both disk I/O and CPU, but they're minimal.

My machine is an Athlon 64 3800+ with 2GB of RAM running XP professional SP3.  I had Comodo Firewall so after reading the other thread where that seemed to be causing the problem I disabled it, but I'm still seeing this issue.

I installed ThreatFire recently.  That may be causing problems so I've disabled it for the moment to see if the issues with FARR clear up.

Any other information I can provide to help track down the issue?

Here's a thread dump from procexp that I grabbed while it was unresponsive, if that's of any help.

ntkrnlpa.exe!KiUnexpectedInterrupt+0x121
ntkrnlpa.exe!ZwYieldExecution+0x1c8e
ntkrnlpa.exe!ZwYieldExecution+0x2570
TfFsMon.sys+0x6694
TfFsMon.sys+0x6d03
TfFsMon.sys+0x6e92
ntkrnlpa.exe!IoBuildPartialMdl+0xed
fltmgr.sys+0x10754
ntkrnlpa.exe!IoBuildPartialMdl+0xed
ntkrnlpa.exe!NtMakePermanentObject+0x11b2
ntkrnlpa.exe!ObOpenObjectByName+0xea
ntkrnlpa.exe!IoCreateDevice+0x745
ntkrnlpa.exe!IoCreateFile+0x8e
ntkrnlpa.exe!NtCreateFile+0x30
cmdguard.sys+0x28fd
ntkrnlpa.exe!KeReleaseInStackQueuedSpinLockFromDpcLevel+0xb74
ntdll.dll!KiFastSystemCallRet
kernel32.dll!CreatePipe+0xa75
kernel32.dll!CreatePipe+0xa47
kernel32.dll!WritePrivateProfileStringA+0x26
FindAndRunRobot.exe+0x13ac8a
FindAndRunRobot.exe+0x13a2ba
FindAndRunRobot.exe+0x70031
FindAndRunRobot.exe+0x6db2b
FindAndRunRobot.exe+0x7be42
FindAndRunRobot.exe+0x7ba2a
FindAndRunRobot.exe+0xcf14b
FindAndRunRobot.exe+0xecb88
FindAndRunRobot.exe+0xcaff4
FindAndRunRobot.exe+0xec2af
FindAndRunRobot.exe+0x135daa
USER32.dll!GetDC+0x6d
USER32.dll!GetDC+0x14f
USER32.dll!DefWindowProcW+0x180
USER32.dll!DefWindowProcW+0x1cc
ntdll.dll!KiUserCallbackDispatcher+0x13
USER32.dll!DefWindowProcA+0xaa
uxtheme.dll!DrawThemeText+0xbca
uxtheme.dll!GetThemeAppProperties+0x595
uxtheme.dll+0x1ac7
uxtheme.dll!GetThemeAppProperties+0x50
USER32.dll!SendInput+0x1c
USER32.dll!GetDC+0x6d
USER32.dll!GetDC+0x14f
USER32.dll!IsWindowUnicode+0xa1
USER32.dll!CallWindowProcA+0x1b
FindAndRunRobot.exe+0xecc84
FindAndRunRobot.exe+0xce16e
FindAndRunRobot.exe+0xecb88
FindAndRunRobot.exe+0xcaff4
FindAndRunRobot.exe+0xec2af
FindAndRunRobot.exe+0x135daa
USER32.dll!GetDC+0x6d
USER32.dll!UserLpkPSMTextOut+0x1cc
USER32.dll!DefWindowProcW+0x180
USER32.dll!DefWindowProcW+0x1cc
ntdll.dll!KiUserCallbackDispatcher+0x13
USER32.dll!SendMessageW+0x49
uxtheme.dll!Ordinal61+0x958e
uxtheme.dll+0x1ac7
uxtheme.dll!GetThemeAppProperties+0x50
USER32.dll!SendInput+0x1c
USER32.dll!GetDC+0x6d
USER32.dll!GetDC+0x14f
USER32.dll!IsWindowUnicode+0xa1
USER32.dll!CallWindowProcA+0x1b
FindAndRunRobot.exe+0xecc84
FindAndRunRobot.exe+0xecb88
FindAndRunRobot.exe+0xcaff4
FindAndRunRobot.exe+0xec2af
FindAndRunRobot.exe+0x135daa
USER32.dll!GetDC+0x6d
USER32.dll!GetDC+0x14f
USER32.dll!GetWindowLongW+0x127
USER32.dll!DispatchMessageA+0xf
FindAndRunRobot.exe+0xd3095

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 35,007
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Donate to Member
Re: [Bug report] Farr freezing on XP for a few minute, then comes back
« Reply #1 on: June 15, 2008, 02:59:30 PM »
I suspect your problem is the one described here:
http://www.donationc...ndex.php?topic=11871

I hope to have it fixed this week.

jaden

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 145
    • View Profile
    • My blog
    • Donate to Member
Re: [Bug report] Farr freezing on XP for a few minute, then comes back
« Reply #2 on: June 15, 2008, 03:26:03 PM »
I saw that thread and thought this was different because the freezes last so much longer than 5 seconds (about 4 minutes on the last one I timed).  My .ini file is only 10KB too, but I'll gladly test out the fix when it's ready!

One more observation.  After I disabled ThreatFire, FARR began cranking on the disk.  I hadn't brought it up or launched any apps but it ran for about 30-45 seconds full speed on the disk, then stopped.  After that, even with ThreatFire enabled, I haven't gotten the hang again.  I did notice a very slight delay on closing (I'm assuming it was the sixth time and the .ini file was being backed up).

My theory is that ThreatFire was keeping FARR from doing some background processing, but I could be way off.

Thanks for the quick reply. 

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 35,007
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Donate to Member
Re: [Bug report] Farr freezing on XP for a few minute, then comes back
« Reply #3 on: June 25, 2008, 05:09:23 PM »
I'd love to get a report on whether the new version (2.12.03) still suffers from this problem.

Armando

  • Charter Member
  • Joined in 2005
  • ***
  • Posts: 2,708
    • View Profile
    • Donate to Member
Re: [Bug report] Farr freezing on XP for a few minute, then comes back
« Reply #4 on: June 27, 2008, 12:03:02 AM »

this is not exactly related but I didn't want to start a threat just for that... I'd like to point out that launching URLs can be quite slow when the browser is not Internet explorer. even if set as default, URLs are launched slowly in Firefox.  I've found that inserting the Firefox path in the "override default Internet browser..." text box in the option window,"external tools"section, accelerates the launching a bit.

jaden

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 145
    • View Profile
    • My blog
    • Donate to Member
Re: [Bug report] Farr freezing on XP for a few minute, then comes back
« Reply #5 on: June 27, 2008, 11:51:23 AM »
@mouser: I just upgraded, but so far I haven't seen that problem.  The new release seems more responsive generally, which is great.

I'll update this thread if I run into the issue, but I think it's resolved.

Thanks for great work on this!