Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • October 27, 2016, 11:43:20 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: [bug report] infinite loop ? with alias  (Read 1809 times)


  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 514
    • View Profile
    • Donate to Member
[bug report] infinite loop ? with alias
« on: May 06, 2008, 04:33:42 AM »
say you have this alias :


^g ((?:[^-]|-(?!-))*)(?:\s*--\s*(.*))?()

$$c | http://www.google.com/search?q=$$c&btnG=Search /ICON=icons\google.ico

if the clipboard contains the string $$c then FARR stops responding, you have to kill it...
i guess it goes into an infinite loop g g g g g g ... $$c

i forgot about this bug, and this morning i copied and pasted an expression with $$c in my post regarding the showhtml command... a few minutes after i google something... and FARR stopped responding...
i took me quite some time before remembering the bug...


  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,338
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: [bug report] infinite loop ? with alias
« Reply #1 on: May 06, 2008, 07:02:12 AM »
thank you for figuring out the nature of this bug, i will fix  :up: