Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 04, 2016, 10:16:50 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Default Hotkey Not Working - Vista on Dell XPS Notebook  (Read 5217 times)

J-Mac

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 2,913
    • View Profile
    • Donate to Member
Default Hotkey Not Working - Vista on Dell XPS Notebook
« on: March 07, 2008, 09:54:48 AM »
Brand new Dell XPS M-1330 notebook running Vista Ultimate. The default hotkey, Pause/Break, doesn't exist on this notebook! There is an Insert/Pause button and a Delete/Break button, but neither bring up FARR.  I tried to edit this hotkey but it is not editable.  The Alt/Space key combination works but I cannot seem to remember that combination -- I always use that after hitting the Insert/Pause key several times; I'm having trouble getting used to the Alt/Space combination. Too accustomed to the Pause/Break key - which I apparently no longer have on this computer!  I had to deselect the Ctrl/Space hotkey, as I use that quite often in another application.

Is there a way I can be permitted to edit the Pause/Break hotkey and replace it with the Insert/Pause?  (I don't want to make it the Delete/Break key, as I'm concerned that will kill the "Delete" function).

Thanks,

Jim

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Default Hotkey Not Working - Vista on Dell XPS Notebook
« Reply #1 on: March 08, 2008, 01:52:15 AM »
you can set custom hotkeys for farr v2 now, as many as you want.
for my laptop i use alt+backspace and find it pretty convenient to type.

yksyks

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 476
    • View Profile
    • Donate to Member
Re: Default Hotkey Not Working - Vista on Dell XPS Notebook
« Reply #2 on: March 08, 2008, 04:22:31 AM »
On my new Dell Inspiron 1720 the Break key has to be typed as Fn-F12, which is not very handy.

I'd like to use CapsLock key, as I almost don't use it otherwise, and this is possible in FARR. However, FARR should disable its original function, because when invoking FARR using CapsLock, all subsequent characters typed are in upper case.

Would this be possible, mouser? (Something like Enso does.) Thanks!

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Default Hotkey Not Working - Vista on Dell XPS Notebook
« Reply #3 on: March 09, 2008, 03:06:23 AM »
I'd like to use CapsLock key - yeah i kind of like that idea.  it fits the model of using the break key -- i.e. to use a dedicated key that isn't useful for much else.

At the minimum I can add support for CapsLock key to TapTap -- the program i wrote specifically to let you use strange hotkeys with any program.

Which reminds me j-mac, you could use TapTap to map something like a double tap of the Control key to launch FARR.

yksyks

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 476
    • View Profile
    • Donate to Member
Re: Default Hotkey Not Working - Vista on Dell XPS Notebook
« Reply #4 on: March 09, 2008, 06:32:41 AM »
I'm already using TapTap on the laptop, but I had to disable it on my desktop because of frequent collisions with PhraseExpress.

nitrix-ud

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 516
    • View Profile
    • Donate to Member
Re: Default Hotkey Not Working - Vista on Dell XPS Notebook
« Reply #5 on: March 09, 2008, 06:37:51 AM »
@yksyks

you could use autohotkey

this should do (this sends alt+space, so you need the alt+space hotkey activated in FARR):
CapsLock::
Send !{Space}
return

attached is a compiled version in case you don't want to install autohotkey

yksyks

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 476
    • View Profile
    • Donate to Member
Re: Default Hotkey Not Working - Vista on Dell XPS Notebook
« Reply #6 on: March 09, 2008, 06:56:58 AM »
Thank you, nitrix-ud. I admit I'm too lazy to learn and use AutoHotKey and I think it's a bit overkill for my needs. Instead, I'm using HotkeyP, which is much simpler to use, I believe. Just before reading your reply I managed to do exactly the same you suggested (but for the Break key). And HotkeyP successfully disabled CapsLock's original function, so everything is solved for me!

nitrix-ud

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 516
    • View Profile
    • Donate to Member
Re: Default Hotkey Not Working - Vista on Dell XPS Notebook
« Reply #7 on: March 09, 2008, 12:42:25 PM »
@yksyks

i'm glad you solved your pb  :Thmbsup:

just so you know, the script i posted disable the capslock function too

cheers