Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 10, 2016, 04:56:22 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Bug: Ctrl C doesn't work (for me)  (Read 4769 times)

dluby

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 220
    • View Profile
    • Donate to Member
Bug: Ctrl C doesn't work (for me)
« on: October 25, 2007, 08:20:28 AM »
Hi,

I've reported this before and I'm curious to know if it happens for others.

I keep copies of my screen captures in SC (ver. 2.37.03). If I highlight an older screenshot in the screenshot panel it appears highlighted (selected) on the main screen, but if I use Ctrl C to copy it, nothing happens.

However, if I reselect the image or press Ctrl A and then Ctrl C, it copies fine.

Am I using this wrong or is it a bug?

Tks

Damian

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,434
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Bug: Ctrl C doesn't work (for me)
« Reply #1 on: October 25, 2007, 11:54:37 AM »
Here's what i think is happening:

You are selecting an older screenshot in the thumbnail panel, and then when you hit ctrl+C it is performing an explorer-style FILE copy, since that panel works just like an explorer window.

So it is copying, just not copying image data to the clipboard, but rather copying the file to the clipboard.  To test, go to windows explorer and hit ctrl+V to paste the new file copy.

What is the solution?  I could add another hotkey that copied the image data in this case. or you could keep doing what you are doing in first selecting all.

dluby

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 220
    • View Profile
    • Donate to Member
Re: Bug: Ctrl C doesn't work (for me)
« Reply #2 on: October 26, 2007, 02:37:43 AM »
Hi Mouser,

Yep, that's it when I do Ctrl V in Explorer it pastes the image into the folder as a PNG file (nice feature that).  If you could, I'd like a different shortcut to paste it into the clipboard.

Tks

Damian