Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 09, 2016, 11:10:56 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Some bugs in v2.36.03  (Read 2636 times)

xcopy

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 76
    • View Profile
    • Donate to Member
Some bugs in v2.36.03
« on: September 30, 2007, 12:22:45 PM »
Running SSC v2.36.03 the program crashes in a special case:
1. Go to your browser or any other program and copy an image to your clipboard
2. Launch SSC and choose "Paste clipboad image/object as new object"
3. When you see the pasted image, still selected, choose "Crop to selection"
4. Choose "Flatten all objects to background"

This gives me an "Access violation at address 004AE63D in module 'ScreenshotCaptor.exe'. Read of address 00000140".
I found that this doesn't happen when you skip "Crop to selection"

Furthermore I noticed another bug when testing this: it wasn't easy to perform step #2
"Paste clipboad image/object as new object" works sometimes, sometimes (mostly) not. I got the feeling that going to the menu and choosing "Paste clipboad image/object as new object" mostly works but when you hit the correspoding keyboard shortcut (ctrl-v) the image shows for the part of a second and then disappears. But I couldn't confirm this; in the latest tests, this paste-function never worked in both variations.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,431
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Some bugs in v2.36.03
« Reply #1 on: September 30, 2007, 12:29:59 PM »
i confirmed some of these bugs, looks like an object pasting bug. it's on my todo list.
the reason that pasting is seeming to fail is because objects are being pasted to a position off screen -- should be an easy fix.
« Last Edit: September 30, 2007, 12:32:13 PM by mouser »

xcopy

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 76
    • View Profile
    • Donate to Member
Re: Some bugs in v2.36.03
« Reply #2 on: September 30, 2007, 12:39:25 PM »
Hi mouser, good to hear. Thanks for the quick response.