Welcome Guest.   Make a donation to an author on the site September 21, 2014, 01:11:20 PM  *

Please login or register.
Or did you miss your validation email?


Login with username and password (forgot your password?)
Why not become a lifetime supporting member of the site with a one-time donation of any amount? Your donation entitles you to a ton of additional benefits, including access to exclusive discounts and downloads, the ability to enter monthly free software drawings, and a single non-expiring license key for all of our programs.


You must sign up here before you can post and access some areas of the site. Registration is totally free and confidential.
 
The N.A.N.Y. Challenge 2014! Download dozens of custom programs!
   
  Forum Home Thread Marks Chat! Downloads Search Login Register  
  Show Posts
      View this member's profile 
      donate to someone Donate to this member 
Pages: [1]
1  DonationCoder.com Software / ProcessTamer / Process won't listen to priority change on: March 23, 2012, 04:15:26 PM
Some of you may remember the "Amateur Scientist" column that used to be printed in the Scientific American magazines. Although they've ended the series, an enormous archive had been made available on CD available from amazon.

Unfortunately, the archive uses a terribly-written search process called "SEARCHSVR_WINDOWS" to sort through the articles. It seems to behave  normally for the first few minutes of use--but will suddenly eat up 95%+ of my CPU usage! Once it reaches this point, the process won't calm down unless I kill it.

After some googling, I decided to download Process Tamer, which installed nicely and was easy to use. I set an exception for the "SEARCHSVR_WINDOWS", telling the Tamer to lower the priority to "Low" if the process took up more than 70% CPU.

Now it turns out that Process Tamer did its job perfectly--once "SEARCHSVR_WINDOWS" had gone rogue, a little pop-up would inform me that its priority had been lowered. A double-check with Task Manager revealed that the priority had indeed been set to "Low".

But... the rogue process WILL NOT LOWER ITS CPU USAGE!! Changing the priority seems to have no effect on it. I even tried setting the exception to "Kill Process", but it still would not budge.  Sad

Any suggestions would be greatly appreciated!
Pages: [1]
DonationCoder.com | About Us
DonationCoder.com Forum | Powered by SMF
[ Page time: 0.023s | Server load: 0.08 ]