topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • August 18, 2019, 03:35 AM
  • Proudly celebrating 13 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - RobFreundlich [ switch to compact view ]

Pages: [1]
1
Find And Run Robot / Request: Customization of Options Dialog font
« on: December 04, 2017, 09:13 AM »
I know this would be a large undertaking, but would it be possible to implement customization of the Options Dialog font face and size? To put it bluntly, my eyes suck, and being able to pick a larger size (and possibly a different face) for the options/settings dialogs in other applications has made a huge difference for me.

2
Find And Run Robot / Re: FaRR not closing after launch
« on: December 04, 2017, 07:39 AM »
I'm pretty sure I bounced it a few times before posting, but this weekend I bounced it for sure (I was trying, unsuccessfully :(, to point my home copy and my work copy at the same myaliases.alias file via DropBox), and the problem went away.

Weird.

3
Find And Run Robot / Change default styles of HTML View Mode?
« on: November 30, 2017, 03:28 PM »
I've just discovered the HTML View Mode feature, and I love it - I'm going to set up cheat sheets for various things like commands and IDE's and so on. One question - is there a way to modify the default styles? The text is on the small side, and I'd like to make it larger. If there's a stylesheet I can change or override, that'd be great.

Thanks!

4
FARR Plugins and Aliases / Re: FARR plugin: FarrWebMetaSearch 1.6.0
« on: November 28, 2017, 08:05 AM »
Download links are broken, and for whatever reason this was quite difficult to find(even though I found it in an obvious place). Smells of the sort of thing that Google has shunned..
FarrWebMetaSearch.zip

The link above should work forever unless explicitly removed or nuclear holocaust.

I've also attached the file.

Thanks for the download link! Unfortunately, all of the configs seem to be terribly out of date - no matter what I try, I get either no results or a neverending search. I wonder if this could be redone to use API's instead of scraping the sites so it could be more resilient.

5
Find And Run Robot / Re: FaRR not closing after launch
« on: November 28, 2017, 07:42 AM »
I'm having this same problem, without the Timezone plugin. In fact, I disabled all of my plugins, and it made no difference. I've checked all of my settings, and they're all set to close on launch.

6
Find And Run Robot / Re: Change location of AliasGroups/MyCustom?
« on: October 30, 2017, 08:19 AM »
I should have searched a little harder. I found a good solution in the FARR v3 discussion.

7
Find And Run Robot / Re: FARR V3 Discussion
« on: October 30, 2017, 08:01 AM »
Btw, I like the pyhton idea with making plugins, as it should be fast enough for majority of plugin needs, but easy enough for everyone to tackle a plugin or two.

I like this, too. I don't know C++ at all, but I do know python (even if it's not my favorite language), so I'd be one of the "everyone" who would tackle a plugin or two. I don't know what they'd be, but I like to tinker  8)

8
Find And Run Robot / Change location of AliasGroups/MyCustom?
« on: October 30, 2017, 07:49 AM »
Is there any way to change the location of the AliasGroups/MyCustom directory?

I use FARR on two computers - one at home and one at work, and would like to have the same aliases in both locations. The way I've solved similar problems in other applications (custom Chrome home page, .emacs file, Stylish settings, etc) is to put the configuration in my Dropbox folder; Drop box syncs it, and voila - shared configuration!

If I could tell FARR to look for AliasGroups/MyCustom in my Dropbox folder, I could do the same thing with FARR. Is it possible?

9
I'm afraid I wasn't able to reproduce the crash on my old laptop running the 32 bit version Windows 7.

snip...

If you want to help track it down I can make you a build with log statements embedded, trying to find the position in the code where it crashes.

I'd be glad to!  The machine in question (at work) is 64-bit Win 7, though, if that helps any.

By the way, I'm back home on my Windows 10 (64-bit) machine, and I can't get this latest version to work at all.  When I type rtm, I get a message about an invalid certificate.

Starting to believe I'm cursed ...

10
It doesn't matter which one I click, and it does fail the same way with 1.1.3


11
I've re-built libcurl with the C runtime linked into the binary and replaced the installer here:

https://dl.dropboxus...54/FarrMilkSetup.exe

No installation of additional runtime should be necessary.

Would appreciate if you could check this one out, even if smart lists seem to be working with 1.1.3 after all.

My only explanation for why it's working again now is a bug / glitch at RTM's side which they coincidentally fixed just now.

It installed and ran this time, I'm getting errors.

In this screenshot, I clicked on entry 5:
FarrMilk-Clicked on entry 5.png

In this one, I hit PageDn to see all tasks, then hit the down arrow to get into the list:
FarrMilk-Hit PageDown Then DownArrow.png

At that point, FARR force-closed.  Could this have to do with my running 64-bit Windows (7 Enterprise, SP1)?

12
For 32 bit software, as FARR is, you'll probably have to install the 32 bit version of the runtime. Eventually, on 64 bit systems, you'll probably end up installing both the 32 and 64 bit version of those runtimes. With current harddrive sizes that shouldn't be a problem. And they'll happily live, independently, next to each other. :)

That makes complete sense and probably explains what I saw - even though FARR is finding the DLL, it's the wrong version and so it can't load it.

13
I installed the VS 2015 runtime at home, and I still can't get FARR to load the plugin.  I suspect it has to do with my system being 64-bit and the runtime installing VCRUNTIME140.dll into Windows/System32, even though I did a 64-bit install.  I tried to cheat by putting Windows/System32 into my path, but that didn't work.  Neither did creating a symbolic link to it in the FARR directory.

However, I tried reverting back to version 1.1.3, and it is now showing me things from my smart lists.  Like you, I don't understand what has changed - why it now works where it didn't before.  So much for computers being deterministic.

14
Really sorry about that. Yes, it should be safe to install the VS 2015 runtime alongside the one for VS 2013. But to be honest, I thought I had the runtime libraries linked into the binary. But maybe I haven't for libcurl. I can't check right now, will do so in a the next 24 hours. Sorry for using you as a guinea pig.

I'll try to get the runtime installed (or will do it at home - like you, I'm juggling a couple of tasks right now and probably will be until the end of the work day).

As for the guinea pig thing, don't worry about it.  I asked for a fix, and you're responding - I'm happy to thrash around in the habitat, squeaking and whistling and whatever other sound they make while you keep tossing me things to try  8)

15
This version wants VCRUNTIME140.dll, which I don't have.

I know that's part of the Visual Studio 2015 Runtime, but I'm a little reluctant to download it since part of the project I work on uses VS and we're still on 2013.  I don't do Windows development, but that piece does build as part of my overall build, so I don't know if putting this on my system will break my build.

Can this version of FarrMilk be installed without the runtime?  Or do you know whether the runtime is safe for me to install?

16
I got an error message "Unsupported protocol":
UnsupportedProtocol.png

and a new entry in pluginlog.txt:
08:43 AM, Tuesday, July 12, 2016
 Error initializing plugin do_init function
C:\Program Files (x86)\FindAndRunRobot\Plugins\FarrMilk\libcurl.dll


17
I am using the ID of the smart list, which does not seem to work. Can you try your query in 3. with only the list_id, but without the filter? And maybe also the list_id with an empty filter? Using only the filter seems to work though, I found this as a solution in the dev forum (and according your test also the filter and the list_id together). I did not keep track of the filter, so I assume the introduction of the filter and the respective change to rtm.tasks.getList is when the functionality broke in FarrMilk.

When I first tried it, I used only the list_id, and got back both complete and incomplete tasks that meet the list's criteria.  So that definitely works.  I just added the status:incomplete filter so that I'd only get the incompletes.

18
I've been playing around with the RTM API, and I found that if you use a Smart List's ID with the rtm.tasks.getList method, it works great.  For example, I made this series of calls:

1. The authentication sequence, leading to an auth_token of 12345

2. http://api.remembert...getList&api_key=my_key&auth_token=12345&api_sig=the right sig

Result:
Code: Text [Select]
  1. <rsp state="ok">
  2. <lists>
  3. ... a bunch of list tags
  4.   <list id="39989832" name="Today's agenda" deleted="0" locked="0" archived="0" position="0" smart="1" sort_order="0">
  5.     <filter>(due:today OR dueBefore:today OR (NOT start:never AND NOT startAfter:today)) AND NOT list:Groceries AND NOT location:brain</filter>
  6.   </list>
  7. ... a bunch of other list tags
  8. </lists>
  9. </rsp>

3. http://api.remembert...getList&api_key=my_key&auth_token=12345&list_id=39989832&filter=status:incomplete&api_sig=the right sig

Result: XML containing the incomplete tasks in my "Today's agenda" Smart List


I didn't try putting the name of the Smart List into the filters since they provide the list_id parameter.  But this seems to work properly, so I imagine it ought to be pretty easy to work into the plug-in, assuming you're keeping track of list ID's.

19
Well, I'm not sure they consider it a bug.

Ok, I will have a look. It's been such a long time since I have last worked on this plugin though, it will take me some time just to build it again.

Thanks!  Sorry to resurrect something from the, uh, Farr past :-)

I went and got myself a non-commercial API license yesterday so I can play around with smart lists and see what's up with them.  If I have some time at work today (in between mentoring my intern, coding my own stuff, and being the weekly liaison from my dev group to support.  /sigh) I'll see if I can get a listing of my main SL.  If not, I'll hit it tonight.  Either way, I'll post back here with my results.

20
Thanks for the quick response!

It bums me out, though, that smart lists don't work, since I tend to work almost exclusively off of a single Smart List which contains everything that's due today, everything that's overdue, and everything that has a start date on or before today (regardless of due date).  In other words, everything I ought to be thinking about doing today.  None of the built-in lists covers that.

/sigh

Time for me to head over to RTM and file a bug report against their API's on your behalf  ;)

21
I can't get the plug-in to show the contents of any of my Smart Lists.  I've read the note about them, so I know they're odd ducks, but it sounds like they ought to work if I've got the option for them checked, which I do:

EnableSmartLists.png

When I try to use a Smart List, here's what happens:

1. The list shows 0 tasks.  I think that makes sense, given what you've described in your note:

TodaysAgenda.png

2. When I select the list, it fills in the command line with what looks the correct syntax:

CorrectSyntax.png

3. When I hit enter, instead of going and fetching the list and displaying its tasks in FARR like it'd do with a normal list, it opens my browser as if I were searching for rtm tasks /list:"Today's agenda"

I know that the Smart List I'm using here as an example has a single quote in it, and I thought that might be the problem, but I tried with another Smart List without one, and it did the same thing.

Can anyone tell me what I'm doing wrong?

Thanks!

Pages: [1]