topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • September 15, 2019, 03:19 PM
  • Proudly celebrating 13 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - ClipPete [ switch to compact view ]

Pages: [1]
1
Clipboard Help+Spell / Re: Errors
« on: February 25, 2016, 10:22 PM »
firs things first, go to options then Backup/Maintenance tab and click on the button 1-down from the top right labeleld "Verify, Repair, Optimize" database.

See if that fixes the problem.

Thanks for helping out mouser!
I tried to do as you said. However...
When I clicked on Options I kept getting this error message pop-up:

TableClips: Field 'Index' not found

I can't even Exit the program!
When I try to from File/Exit I get the same error message as above.
Or clicking on the top right 'x' gives the same result.



2
Clipboard Help+Spell / Errors
« on: February 25, 2016, 06:43 PM »
I use CH&S occasionally with Excel and have been getting a whole slew of errors recently from it.
I don't have any idea what they're all about or what is causing them.

Here are a few of them:

Error DB65: DBISAM Engine Error # 11949 SQL parsing error - Expected expression but instead found ) in Select SQL statement at line 1, column 50

Error DB65: DBISAM Engine Error # 11949 SQL parsing error - Expected expression but instead found ) in Select SQL statement at line 1, column 30

Error EXDE29: Operation aborted

TableGroups: Field 'Index' not found

Do you have any idea about them and what I can do to remedy the problem?
These errors don't just pop up once and go away.
They repeat themselves sometimes 10+ times in a session.

TIA!

3
Clipboard Help+Spell / Re: Closing window
« on: October 01, 2014, 04:47 PM »
Try beta:

Thanks Mouser for that!
I tried out the code with my script and it is working nicely.

As I was working with my script (AutoHotKey) just now, trying to fix up a couple of other things, I noticed another line in my CH&S code that jumped out at me.
It was: Send, !{F4}

Sure enough when I tried it out, (it was code that I had been using later on in my script) it also was capable of closing CH&S. :)
Usually Alt-F4 will close down a program, but for some reason it just closes the CH&S window (which is exactly what I wanted).

I noticed that the .exe is quite a bit larger than the previous version, so I hope you made a few more adjustments besides the Ctrl-Alt-W.  :)

Thanks again for your help, I really appreciate it.

It took a while before I was able to get your program to copy a few fields and store them so I could later retrieve them for use in Excel (all with keystrokes), but I finally figured it out earlier this year.
Yours was the only clip program I tried that could accomplish this.  :)

4
Clipboard Help+Spell / Re: Closing window
« on: September 26, 2014, 09:21 PM »
i will add it for next release (ill try to get a beta out this weekend).

Thanks very much mouser, I really appreciate it.   :)

5
Clipboard Help+Spell / Re: Closing window
« on: September 26, 2014, 09:03 PM »
If I make ctrl+alt+W toggle the window closed if it is already showing, would that solve your problem?

Yes that would solve my problem! 
If you could do it that would be great.  :)

6
Clipboard Help+Spell / Closing window
« on: September 26, 2014, 08:52 PM »
Hi Folks,

I had CH&S set up to accomplish one particular task. It was working nicely.
The program I was using it with, changed their code and is now giving me problems.

In order to fix the problem I would like to know how I can close the CH&S window using keystrokes?

I know I can open the CH&S window by using the hotkey: Crtl-Alt-W.
What is the hotkey to close the CH&S window?

Right now the only way I can find to close it is by mouse clicking the 'x' in the top right corner.
I don't want to close the program, just the window.

TIA!





7
Clipboard Help+Spell / Re: DBISAM Engine Error # 9732
« on: July 09, 2014, 08:53 PM »
But it is very unlikely that simply changing a file association of .dat files could have done this, so I wouldn't be too quick to blame yourself or another program.

OK.  :)
Anyway, the main thing is that it's working again and I think it will be fine for some time.
Thanks again!

8
Clipboard Help+Spell / Re: DBISAM Engine Error # 9732
« on: July 09, 2014, 03:10 PM »

The "Database" subdirectory inside your ClipboardHelpAndSpell directory.
This will either be in the installation directory if you are running portably or on Windows XP.
On Windows 7/8 it will be under MyDocuments\DonationCoder\ClipboardHelpAndSpell.

Thanks Mouser!

I am back in business.  :)
I'm running WinXP so I found the folder in my programs folder.

After I deleted the database files and started the program it's running fine again.

I noticed that a couple of the files in the database folder have a .dat suffix.

I believe this is where the problem started.
A couple of days ago I was having problems with a password program.
I noticed that the password database file had been taken over by another program!

So I changed back the program that controls .dat files to the Password program.
I believe this was my mistake.
In doing so, I think the program took over ALL .dat files.

So when CH&S needed its .dat files they weren't available to it.
That's my theory, and I think that's what happened.

So I went into Total Commander and released all .dat files. Now no single program controls all of the .dat files.   :)





9
Clipboard Help+Spell / Re: DBISAM Engine Error # 9732
« on: July 09, 2014, 02:03 PM »
Or, even before you try restoring from a backup, you might try exiting CHS, moving all files out of that Database directory, and then restarting CHS to give you a completely empty blank database.  Make sure that works without any errors, and then try restoring one of those backups.

I think I'll go with this advise rather than the above, because it's simpler and I don't really have anything important in the backups.

Now I couldn't follow the path you gave to get to my database files. I used another path.
I deleted two .dat files. Are these the database files?  DonationCoder_clipboardhelp....dat  and another>

After I deleted them, I still got an error message.
So we're not quite there yet.

I have an idea as to why this all started, but I'll explain that later.
I'd just like to get this working again first.

I didn't see a folder called 'Database'.

Any ideas on how to proceed?
Thanks again!

10
Clipboard Help+Spell / Re: DBISAM Engine Error # 9732
« on: July 09, 2014, 10:55 AM »
Close the error message(s) and then go to Options dialog and then to the Backup/Maintenance tab, and then click "Verify or Repair Database".
See if that helps.

Thanks for helping out!

This seems a bit more serious than what I initially posted.

I'm getting many error messages:

DBISAM Engine Error # 9732 A value must be provided for the field 'Index' in the table 'Clip Table'

Error DB65: DBISAM Error # 11949 SQL parsing error - Expected expression but instead found ) in SELECT SQL statement at line 1, column 50

Error EXDE29: Operation aborted

Error DB65: DBISAM Error # 11949 SQL parsing error - Expected expression but instead found ) in
DELETE SQL statement at line 1, column 30

TableGroups: Field 'Index' not found


If I try to go to Options as you suggested, I get:
"TableClips: Field 'Index' not found"

11
Clipboard Help+Spell / DBISAM Engine Error # 9732
« on: July 09, 2014, 09:25 AM »
CH&S had been working nicely for the past few months.
All of a sudden today I started getting this message:

DBISAM Engine Error # 9732 A value must be provided for the field 'Index' in the table 'Clip Table'

and the program is not working at all as a result.
Any suggestions on how to fix this?

TIA

12
Clipboard Help+Spell / Re: Delete clipboard items
« on: April 09, 2014, 03:34 PM »
Right click on the group name in the left hand group tree, and choose delete all clips in group.

Thanks again Mouser! :)

13
Clipboard Help+Spell / Re: Quick Paste pop-up
« on: April 09, 2014, 03:33 PM »
Ok so there are two issues -- first, if you want to keep the clips open and paste multiple ones, just use ctrl+alt+W to show the main window and then double click items to send them to the last window.

Second, if you want to paste items and move down the list so that each new paste gets you the next one down, then what you are looking for is the "STACK" feature.

Thanks Mouse for your help and also the welcome.  :)

14
Clipboard Help+Spell / Delete clipboard items
« on: April 08, 2014, 05:40 PM »
Is there a quick way to delete all of the clipboard items?

Both the Old and New items?

If so, what would be the hotkeys to accomplish this?

Thanks!

15
Clipboard Help+Spell / Quick Paste pop-up
« on: April 08, 2014, 04:58 PM »
Hi folks I'm new to this software and still have much to learn about it.

It looks like it has many great features that I hope to discover.

About the Quick Past pop-up.

Right now when I pop-up the Quick Paste and select "1" to paste it, the pop-up disappears.
Is it possible to keep the pop-up on screen until it is closed manually?

Or if that is not possible, are there hotkeys to pull up New Clipboard Items for quick pasting?

Say Ctrl-Alt-1 for a quick paste of the first new clipboard item into the current document?
And say, Ctrl-Alt-2 for a quick paste of the second new clipboard item into the current document? 
etc.

Thanks!




Pages: [1]