topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • October 23, 2018, 10:11 PM
  • Proudly celebrating 13 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - AEN007 [ switch to compact view ]

Pages: [1] 2 3next
1
Skwire Empire / Trout/bass? buffering?
« on: September 28, 2012, 09:11 AM »
28September2012
Greetings.
Every time there is any network activity to/from my PII XP laptop while Trout is playing,
the playback "cracks up". This does not happen with (any) other players (that have buffering [set]).
I'm guessing Trout has no buffering and that this is why the playback cracks up?
Maybe something to consider?

2
18September2012

I have tweaked my script to the following»
Code: Autohotkey [Select]
  1. StatusBarGetText, CPU, 2, Windows Task ahk_class #32770
  2. StringSplit, StrSpl, CPU, %A_Space%, `%
  3. If (StrSpl3 > whatever)
  4.  Process, Priority, whatever.exe, High
  5. else Process, Priority, whatever.exe, AboveNormal
  6. AHk2pid := ErrorLevel

3
25June2012

Greetings.

Well, today I FINALLY worked out how to use GetProcessTimes (GPT) in an AHK script.
Many thanks to Skwire for the reply with the link to the AHK forum thread ...

However, from what I can tell, GPT does not retrieve CPU usage values
that are in any way close to those reported by Windows Task Manager,
and half the time or more often GPT retrieves a CPU usage value of zero ...
There is probably no need to elaborate ...

I searched the web with "autohotkey process cpu usage" and
found an AHK forum thread with some code that uses»
ControlGet, var, List, , SysListView321, Windows Task ahk_class #32770.
I came up with some quicker/simpler code that will allow my AHK scripts
to determine the (WTM) CPU usage of any running process ...
so unless there is some discussion (of value) to follow,
I guess I am finished with this thread ...

4
Skwire Empire / Re: format Trout StatusBar?
« on: June 18, 2012, 03:17 PM »
The post I made suited my purposes, and
I will continue to make posts as it suits me ...

5
Skwire Empire / Re: format Trout StatusBar?
« on: June 18, 2012, 02:45 PM »
... and here is how it looks in its 1st iteration ...
(1st time I've ever used the AHk "Progress" command ...)

6
Skwire Empire / Re: format Trout StatusBar?
« on: June 18, 2012, 01:38 PM »
Are you positive you're using the latest Trout?
... No pun intended.
1.0663. what pun?

I suppose that maybe the problem is that I do not have Trout maximized,
so maybe that "field" could/should be right justified?

I really don't even need the info from StatusBar Path field at all.
I just initially mentioned this issue, because I noticed (long ago),
that all I could (usually ever) see in that field was a partial path and thought that ...
... the filename without any path or with just the last subdir name ... would look better ...
How about %drive%\ ...\folder\song.mp3?
I "see"/find no value in any of the intermediate filepaths ...
and presume I am not (always) the only one who would have such a thought ...

I have some #Persistent AHK scripts -
one of them manages the laptop(s) when MM apps are running.
For the fun of it I'll trying using StatusBarGetText and then maybe SplashTextOn
to make the TE/TR values visible when I do not have my face right up in front of the laptop.

7
Skwire Empire / Re: format Trout StatusBar?
« on: June 18, 2012, 12:05 PM »
One can see in the enlarged image that the filename is truncated but the path is not.
I am running XPProSP3.

I make suggestions that would/could improve Trout.
You seem to be more interested in being the boss ...
No matter ... at one time Trout was the first/only audio option
I was able to make work on my PII XP MM laptop ...
but now (as I have previously posted elsewhere) I have multiple MM options ...

8
Skwire Empire / Re: format Trout StatusBar?
« on: June 18, 2012, 10:19 AM »
Why is is the PL# section so/too wide?
It's that wide so it can handle two six-digit numbers and the slash e.g. 888888/888888
how often does anyone load more than 999 items into Trout? I never do ...
Which OS are you using?
... see previous post(s) ...
Also, that screenshot has been reduced in size making it very hard to see the path at the bottom.
... well zooming with an image viewer/editor makes it clearer ...

9
Skwire Empire / Re: bass plugins
« on: June 18, 2012, 09:33 AM »
18June2012

seems the "official" name is basswv.dll,
but TagS changes the name to bass_wv.dll ...
Trout does not change the name ...

10
Skwire Empire / Re: format Trout StatusBar?
« on: June 18, 2012, 09:27 AM »
18June2012

Well, I am not seeing the full filename of Da=19651103a06-EMRain.mp3
...
I am loading "relative path" m3u files - if that makes any difference ...
except for maybe the drive and the final directory name,
none of the path seems worth showing/seeing ...
seems to me it would be best to allocate most of the 127 chars to the filename ...

11
Skwire Empire / Re: format Trout StatusBar?
« on: June 17, 2012, 06:59 PM »
18June2012

OK ... well, I now see a difference now that I have tested a long enough path;
however, I still see only a partial filename (with a partial path).
My point was/is that the filename without any path or with just the last subdir name
is more important (to me (alone?) or to everyone in general?) than the drive and/or toplevel dirs.
A partial path & partial filename gives rather limited info ... less than a full filename alone ...
How about c:\ ...\folder\song.mp3?

Why is is the PL# section so/too wide?

12
Skwire Empire / Re: bass plugins
« on: June 17, 2012, 06:51 PM »
It seems the plugins bass_aac, bass_alac & bass_ape included with Trout are out of date ...
likewise for the main bass.dll 2.471 vs 2.490
(My) Trout will play .wv files, because TagS includes the basswv.dll ...
in case that is of interest to anyone other than me ...

(My) Trout will play .wv files, because TagS includes the basswv.dll ...
Trout includes the basswv.dll as well so I don't know what you're trying to say here.
never mind ... it's been a long day ...

13
2December2011
Still hoping for a solution.
Any helpful replies/insights appreciated ...

14
Skwire Empire / Re: format Trout StatusBar?
« on: June 17, 2012, 01:56 PM »
12June2012

Greetings.

I just "installed" Trout 1.0663 (portable) but
do not see any change in the StatusBar Path section.
That section still displays the full path from left to right,
which means I see only the partial full path with no filename ...

15
Skwire Empire / bass plugins
« on: June 17, 2012, 01:52 PM »
17June2012

Greetings.

I have Trout (portable) "installed" in the same directory
where I have TagScanner (portable) "installed"
Both use the bass plugins, so I do not have to have
the same bass plugins in two places on my harddrive.

It seems the plugins bass_aac, bass_alac & bass_ape included with Trout are out of date ...
likewise for the main bass.dll 2.471 vs 2.490
(My) Trout will play .wv files, because TagS includes the basswv.dll ...

16
Skwire Empire / Re: format Trout StatusBar?
« on: June 17, 2012, 12:42 PM »
17June2012

Greetings ...

well I hope you will reserve some space in the back of your mind to consider some way(s)
to make the StatusBar TE, TR, CPU% & PL# sections more readable.
Simply giving an option to BOLD them might be easy/enough ...
foobar (of which you are a fan) allows various formatting of the StatusBar ...
as I'm sure you know.
foobar also allows hiding buttons (& menus ...)
My opinion is still that those Trout playback buttons eat up valuable
screen real estate that could be put to better use - like for the SeekBar display ...

Putting $time_t and/or $time_e in the SeekBar ...
... is redundant;
... requires extra CPU usage (20-30 "basis points" on my MultiMedia XP PII);
... causes the seekbar display to flash every second with each token update;

For the last few years I have been running my MM XP PII in 16bit
(instead of 24bit) color because of the reduced CPU usage when running MM apps.
I have made some config changes to the XP install on my MM PII
and find that it can now handle 24bit color - except that CPU usage
for Trout (with $time_t and/or $time_e) & SpecLab runs around 90% ...
Trout&SpecLab without $time_t and $time_e runs around 60% ...
as does foobar&SpecLab ... even with the foobar Peak Meter also running.

What is the diff between the foobar VU & Peak meter?

What about some kind of fix for the Trout local hotkey bugs/problems?

17
Skwire Empire / format Trout StatusBar?
« on: June 16, 2012, 05:27 AM »
16June2012

Greetings.

How about users being able to set some Trout StatusBar formatting?
I would like to BOLD the TE, TR, CPU% & PL# sections and
set the font/background colors to lime on black
(like the/my SeekBar items ... for reference
 see one of my previous postings with upload images ...)

Also the final field with the pathed item playing is not wide enough (for my items).
Maybe the PL# section is too wide?
Also maybe users could be able to select how much (if any) of the path to show there?
... like maybe only the filename without any path or with just the last subdir name?

18
Skwire Empire / Re: Trout playlist contextmenu bugs?
« on: May 08, 2012, 06:19 AM »
8May2012
16January2012
I am wondering if in the future there will ever be a Trout release
without these local hotkey problems?
No offense, I (otherwise) love Trout - but with these local hotkey bugs,
Trout should not be / (never have been) award-winning ...

19
Skwire Empire / Re: Trout playlist contextmenu bugs?
« on: January 16, 2012, 04:15 AM »
16January2012
I am wondering if in the future there will ever be a Trout release
without these local hotkey problems?

20
Skwire Empire / Re: playback status from Win API SendMessage
« on: December 19, 2011, 04:11 PM »
Well, the XMP GUI (like the CP GUI) gives no indications of playback status
and unlike the Trout/foobar GUIs cannot be tweaked with user formatting to do so;
but XMP responds to the WA APIs, so that is what started me on the SendMessage path ...

Controlling CP & MPlayer has not been the issue except that it is / has been impossible
to determine with a script whether either is playing or was actually paused
by the script command to pause the app ...

Today I also read here» CP
6: I would like to write a remote control for CoolPlayer, how can I do this?

A: It's possible to send Accelerators to the main CoolPlayer window for all playing controls.
If you send me an e-mail I will send you the messages.
I sent an email but do not know if I will ever receive a reply or not ...

Well, I hope to find some way to determine with a script the MPlayer playback status

21
Skwire Empire / Re: playback status from Win API SendMessage
« on: December 19, 2011, 03:44 PM »
No ... I have not tried
because
1) that is not what I am after ...
I would like to determine with a script whether CP is playing/paused/stopped.
2) CP (unlike Trout) responds to local hotkeys sent by an AHK script.
The CP local hotkeys are the same as WinAmp's ...
and like WA's they are hardcoded and non customizable ...
Code: Autohotkey [Select]
  1. WinActivate, ahk_class CoolPlayer
starts playback ... I guess like the 40010 would ...
3) I do not know the full syntax in any case.
I guess any of those CP codes would replace the 0x400? like ...
Code: Autohotkey [Select]
  1. SendMessage, 0x40010, ?, ?, , ahk_class CoolPlayer
What would be the correct syntax in any case?

I would guess it is certainly possible to use SendMessage with CP & MPlayer
to determine playback status. I hope to find out how ...

22
Skwire Empire / Re: playback status from Win API SendMessage
« on: December 19, 2011, 02:48 PM »
19December2011
Wow ... I hit the jackpot by posting here ...
My interest in messaging CoolPlayer is mostly just to resolve a long standing "open item" of mine ...
how to determine CP playback status in a script because the GUI gives NO indication at all ...
CP uses the least CPU usage of any mp3 player I have encountered, but
I phased CP out of usage because of the no playback indication issue.
I have no real need/desire to put CP into my rotation of multimedia players ...
but it would/will be nice to have resolved this long standing open item ...

I need to ask/clarify something further.
I use the following items»
Code: Autohotkey [Select]
  1. SendMessage, 0x400, 0, 104, , ahk_class COWON Jet-Audio MainWnd Class
  2. SendMessage, 0x400, 0, 104, , - Trout ahk_class Winamp v1.x
  3. SendMessage, 0x400, 0, 104, , ahk_class Winamp v1.x
  4. SendMessage, 0x400, 0, 104, , ahk_class XMPLAY-MAIN
The AHK ErrorLevel is 0 when stopped, 1 when playing & 3 when paused.
The only thing that changes is the name of the receiving window.

It is (still) not (immediately) clear to me what syntax I should use with CoolPlayer.

Because I often use MPlayer (on my PII) for avi playback,
I would REALLY like to crack the SendMessage format for MPlayer ...

23
Skwire Empire / Re: playback status from Win API SendMessage
« on: December 19, 2011, 10:06 AM »
19December2011
Greetings.
Thanks for the reply.
Today I found the following statement about CoolPlayer»
A: It's written in 'C' and plain Windows API's
Wouldn't all/any players that use Windows API's reply to the same syntax?
Anyway, I have no idea how to go about this.
What might be some standard syntax possibilities to try?
Any helpful replies/insights appreciated.
Thank you.
Regards

24
Skwire Empire / playback status from Win API SendMessage
« on: December 19, 2011, 05:22 AM »
19December2011
SendMessage to WinAmp (or players that support WinAmp APIs like Trout)
to determine playback status (playing/paused/stopped) is»
Code: Autohotkey [Select]
  1. SendMessage, 0x400, 0, 104, , ahk_class Winamp v1.x
I would like to know the SM syntax for players (like CoolPlayer)
that use Windows APIs instead of WinAmp APIs ...

25
Skwire Empire / Re: Trout playlist contextmenu bugs?
« on: December 15, 2011, 06:39 AM »
15December2011
Greetings.

I have determined the source of the problem!
Trout has local hotkey "bug".
The hotkeys should only "intercept" keystrokes when the main GUI is active -
not when windows of any kind of the main GUI are "open".

There is also an enter key problem.
Enter/Return starts playback even if not set as a local hotkey.
If I do ALT-SPACE for the #32768 window/GUI menu with &Move/&Size/Max/Min ...
(the &hotkeys do not work if I have a local hotkey set like "M" or "S")
... then choose Move or Size, then hit ENTER to finish the Move/Size,
Trout will start playback ...

Pages: [1] 2 3next