topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • July 20, 2018, 05:56 AM
  • Proudly celebrating 13 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - mysteryman [ switch to compact view ]

Pages: [1]
1
Hey,

 I used to have a toshiba laptop with a built in card reader (but i believe this is how most builtin card readers function) which would not show up until you inserted a card in the slot. With a single slot, especially on a laptop this isn't entirely useful, but I've searched all over for this functionality on a desktop media reader. I have bought 3-4 of them already (not just for this reason, for more reader types, speed, etc) and none of them do it. They all assign a drive letter continually.

 My current multi-reader has 4-5 drive letters assigned to it ALL the time. When you add this to the 8 or so hdds, dvd drive, virtual drives, network drives, etc... its a fustercluck to say the least *chuckle*. I only use my media reader once every couple months, and when i do, its usually for a single port. There is no reason I should give up 4-5 drive letters, and clutter my "my computer" with these unnecessary items.

 First, does any software exist that would remove the drive letters from selected usb drives (wouldn't want this for usb stick / removable hdd) and mount it (yes, i know, not really a windows term) whenever there was a disk inserted? If not, would anyone be interested in coding this?

 One possible way (though i would prefer a better way if anyone knows one) would be to mount each of the drives to a directory thats out of the way. Then have some application scan each directory and mount it to a drive letter if its got something in it. This is not a preferred method, since this would require the card to have at least one file on it. So the card would not work directly out of the packaging when purchased.

2
Find And Run Robot / bug in regex processing? or bug in my regex?
« on: December 30, 2007, 04:57 PM »
This is related to the shipmenttracking.alias i updated last night (this morning). Before i posted the alias file, i tried to combine the keyword based, and regex based regex's together into one single regex to simplify future updates (if ups, etc changes their check url)
the regex for ups that i believed would work (and kinda does) is this

^(?:ups (.*)|(1Z.*))
-regex

my understanding, is that this regex should return either, but not both (.*) or (1Z.*) as $$1. However look at the results of what it does, and feel free to test

$$1=1Z1
-ups 1Z1
see, this works... it detects the first one works, then skips to the end of the (?:)

$$1= | $$2=1Z1
-1Z1
this one does not work. It appears that each time it processes a ()  that does not lead with (?: that it counts up one variable. It seems it does this irregardless of matching. This first (.*) gets counted as 1, even though it does not match (seen by the null return of $$1), and should be ignored (correct me if i'm wrong), then it procedes to check the other half of the (?:) . It does return a match, but instead of returning a match on $$1 like it should (again, correct me if i'm wrong), it returns it on $$2. making it very difficult to make one alias work for both of them


if there is another way to do this, or if i am using the incorrect syntax for the regexp, please let me know...

3
Find And Run Robot / paste command great, lacking special whitespace
« on: December 16, 2007, 12:16 AM »
hello,

i have been playing with the beta with the paste command for a while, it is great, unfortunately there are some bugs with using special whitespace (tab, newline, etc) I can only assume this may effect some special characters as well, but perhaps not.

I have tried every variation of \t \n \r\n etc, none of these work... I then tried to copy and paste directly into faar's config window a tab, it was read as a space. another possible fix would be to use (or optionally allow) "s or {}s around the text being pasted. to avoid confusion with pasting "s, it may be best just to use the special char escape sequences... your call


4
Find And Run Robot / bug with some characters such as [ and ]
« on: November 10, 2007, 10:26 PM »
hello, I have a number of directories which begin and end with [ ] brackets which seem to show up in results when they match, regaurdless of whether they are set in pattern scoring as -9998. I also tried with ? instead of the [ ] chars as well as with \[ \] none of these characters have been accepted, i believe that farr is trying to execute the code cause its wrapped in []s

incase it matters, i'm using farr2 with pattern scoring using modifier keywords and modifier keywords in the search folders section as well

5
there was a similar request on this post but the person asked for a reason that was already fulfilled by the existing builtin tool.

the builtin tool (im sure your all familiar so i'll be brief) has a little green icon in the system tray; when single clicked, lists removable drives and when clicked, they will be "safely removed". It also has a double click window which imho is less useful and more prone to mistakes, so i dont care if it has this; but it could be added if the coder wants.

this tool for the most part works perfectly, for removable hard drives and flash drive sticks, which plug into usb, or firewire; it OFTEN works on sata hard drives, but this depends on drivers for the card/chipset in question. the reason it does NOT work right is this: (going on half speculation) the driver coding team, must impliment SOMETHING which allows windows to know that this device is allowed to be safely removed. before you jump on me saying that some sata controllers simply do not support hotswap, i must stop you right there, please continue reading.

i have a asus m2n32-sli deluxe motherboard. it comes with two onboard sata2 controllers, one with 6 ports internal, and one with one internal, and one external. the 6 port device runs on the nvidia chipset; the other runs a SiI 3132 chipset. both of these controllers DO support hotswap, which i have confirmed with the KB on their respective sites. however, the SiI site says this in their documentation

http://12.24.47.40/al/12/106/10744.htm (this url is linked from SiI site, confirm if you wish, siliconimage.com then support, knowledge base, it puts you on a page with 12.24.47.40 ... then search for "hot plug", the title is called "SATA: Hot Plugging Drives Under Windows 2000/XP"
This feature is not explicitly highlighted in our current drivers, but all SATA controllers from Silicon Image do support hot plug capability. To remove a drive from a powered up system, do the following:

    * Enter the Windows Device Manager (through Control Panel or right clicking on My Computer and going to Properties)
    * Go to Disk Drives and find the disk you want to remove
    * Right click on the desired disk drive and select Remove/Disable
this works, of course, but it is annoying to do all the time for my hotswap bay, which is hooked up to the SiI plug, the app i would love if somone coded, would either be able to detect all sata and removable drives, and correspoding drive letters, and when clicked, allow that procedure to be done

however i would much prefer if it was customizable (might be outside of scope of this site) to have a include only or exclude list so that i could say... list only usb drives, and the one sata2 port i use for hotswap... and not the other 6 ports as most of my drives are the same model, and its sometimes hard to differenciate between them

Pages: [1]